Sign in with
Sign up | Sign in
Your question

Asus Xonar Echo Problem

Last response: in Components
Share
December 2, 2011 1:12:06 AM

Hi,

I am new to the sound card world and I just purchased an Asus Xonar DG 5.1 sound card. I am using Turtle Beach Z6a 5.1 headphones and before I installed my soundcard, the audio worked perfectly. Since I installed the soundcard, whenever I enter a game, the audio seems to generate a echo. It does not occur when I listen to music, just when I game.

I am using the 8 channel setting with a 96KHz sample rate. I also have the newest drivers from Asus.

Any help would be really appreciated.

EDIT: The echoing is not in all my games apparently. Splinter Cell Conviction sounds fine, but the two games that I play the most (Skyrim and Battlefield 3) have some awkward echoing. I think it may be because of the 5.1 than the sound card.

But if you have suggestions, please let me know
a b Ĉ ASUS
December 2, 2011 10:57:55 AM

Hmm...first, make sure GX mode is disabled; I've seen the Directsound emulaton layer do some wierd stuff from time to time, and this kinda sounds like a problem I had in Mass Effect with GX enabled...

Secondly, its possible some of the enhancement modes are causing the echo; try testing with the Hi-fi preset and see if that causes the echo to go away.

As far as BF3 goes, what are the internal audio settings you are using within the game? Some of the sound modes can create a significant amount of echoing.
m
0
l
February 24, 2014 2:45:48 AM

gamerk316 said:
Hmm...first, make sure GX mode is disabled; I've seen the Directsound emulaton layer do some wierd stuff from time to time, and this kinda sounds like a problem I had in Mass Effect with GX enabled...

Secondly, its possible some of the enhancement modes are causing the echo; try testing with the Hi-fi preset and see if that causes the echo to go away.

As far as BF3 goes, what are the internal audio settings you are using within the game? Some of the sound modes can create a significant amount of echoing.


I had to revive this thread since i was heaving kinda the same problem stated by the OP.. Fortunately through gamerk316's tip i was able to kill the problem, at least for now..

I was trying to use Stereomix to make some recordings but it was echoing like crazy, everything that i played echoed, i tried then turning GX mode off but the problem persisted, then i found this thread and followed gamerk316's tip, which is basically to enable Hi-Fi mode, and by doing so the echo was gone.

Thank you
m
0
l
April 19, 2014 5:22:16 AM

Enable AEC.....Worked for me :pt1cable:  hope this helps
m
0
l
!