Sign in with
Sign up | Sign in
Your question

USB Issues on z77 Extreme4

Last response: in Motherboards
Share
September 9, 2012 1:10:49 AM

Hello,

I just intalled a Z77 Extreme4 motherboard. I also installed and internal SD card reader using one of the USB 2.0 headers. Windows doesn't see recognize the reader. I double checked and it's plugged in correctly. I downloaded a driver from Inland (card reader brand) and still nothing. I'm not sure if it's related, but 2 USB 3.0 inputs on the back panel don't work in the rear either. They are located at the top of the panel, next to the P/S 2 input. The rest of the USB2.0/USB3.0 inputs work just fine. The card reader is the only component using the USB 2.0 headers. I made sure all the drivers on the CD are installed.

Any help would be greatly apreciated.

Thanks,

Mike
September 28, 2012 8:04:19 AM

AsRock Support sucks.... thats what I have learnt.
having detection problem with my HDD.
m
0
l
September 29, 2012 6:19:45 AM

try to check the CD that came with the motherboard. as i've remembered there was a folder for USB3.0 that has a .exe file. i dont know if that helps but i had it installed without any problems.
m
0
l
Related resources
September 30, 2012 12:32:28 PM

Many of the older card readers don't work or give problems on Win7 and 8,

but you'll find they are charging a premium on card readers marked 'win7 compatible'.
m
0
l
October 12, 2012 2:21:09 PM

I case someone ends up in this post searching for a solution... I had the same problem, and it was solved with BIOS update.
m
0
l
!