Sign in with
Sign up | Sign in
Your question

Sabertooth Z77 - Screeching/white screen. UPDATE: 460 works, 570 don't

Last response: in Motherboards
Share
September 11, 2012 2:24:37 AM

Edit: Another issue has appeared. In BIOS I set the advanced option for graphics to iGPU instead of PCIE to try to use the onboard graphics, and now I get no graphics at all and cannot do anything.

Specs:

Intel Core i5-3570K Ivy Bridge 3.4GHz (3.8GHz Turbo) LGA 1155
ASUS SABERTOOTH Z77 LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
COOLER MASTER HAF 932 Advanced RC-932-KKN5-GP Steel ATX Full Tower Computer Case
COOLER MASTER Hyper 212 EVO
Arctic Silver 5 High-Density Polysynthetic Silver Thermal Compound
x2 (8 GB total) - G.SKILL Ripjaws Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-4GBRL
Intel 330 Series Maple Crest SSDSC2CT120A3K5 2.5" 120GB SATA III MLC Internal Solid State Drive (SSD)
EVGA SuperClocked 012-P3-1572-AR GeForce GTX 570 (Fermi) 1280MB 320-bit GDDR5
OCZ GXS700 PSU
Some Liteon optical drive



Sometimes the screen is white, sometimes medium blue, sometimes GREEN!! The screeching stops and the screen goes blank just before the colored screen(s).

Just built today. Previous had the GTX 570 & power supply playing fine on another system for months, just moved them over. Everything else is new. This happened before AND after the Windows install.

When I start the PC everything seems fine (temps are low from what it shows, no heat coming out), but after a while it starts this loud screeching sound, then it stops and shortly thereafter I get a white or blue screen. It just sits there then. I managed to install Windows 7 64 bit on the SSD, but that's as far as I got. I wanted to stop before something is permanently damaged if it isn't already.

I have the 4 pin cpu-1 of the PSU hooked into the right side of the 8 slot atx power at the top of the motherboard. I have the SSD using the Intel Z77 6 GB ATA connector, with a sata power thing hooked into it also (is this right?). I have all the fans hooked to the power supply, but I didn't insert the small 4 prong things into the Cha_Fans because I wasn't sure if this was necessary. All fans are running fine, and I have tried unplugging them and the motherboard fans (2) to see if that was causing the squealing; none of the fans are. USB 3 plugged in MB but not in use. Using Asus Q Connector (power sw, reset sw, ide_led etc).

Please help. I'm not an expert but I have built my PCs in the past and never had this issue. I appreciate your time. If you need more information just ask.
a b V Motherboard
September 11, 2012 3:16:57 AM

You may need a psu that will provide the 8 pin power to the motherboard, the screaching sounds like to me its a power issue from the psu

Best to get a new psu with the 8 pin power.

What psu are you using?
m
0
l
September 11, 2012 3:21:42 AM

OCZ GXS700 PSU (700W)

THere is a CPU 1 and CPU 2 power connector, each having 4 pins. Do I need to plug both in or just get an entirely new PSU? I was told this one would work but I am of course willing to try it after other suggestions and feedback.
m
0
l
a b V Motherboard
September 11, 2012 3:23:42 AM

Yes you must plug them both in if its available, some mobos can work on one , others need two. Plug both in and give it a try , let me know how it goes.
m
0
l
a c 462 V Motherboard
September 11, 2012 3:34:06 AM

the issue with 4 or 8 pins came up on on the rog forum. asus tech there said it fine to run any of the asus mb with 4 pins or 8 pins as long as the power supply can supply the output needed for the 12v lines. first with the sabertooth mb make sure your running the 1504 bios. anything lower does not have the cpu code for the new cpu and ram. with the ipgpu turned on if you install the mvp software it will cause the mb to hang...it an issue with the software. your issue sounds like the sound card and another device are usign the same irq and memory range.I would start before you used the usb flashback to clear the cmos and put the mb back to factory default. then use the usb flash back..download bios 1504 and rename it z77st.cap put it on a root of a usb stick. plug the usb stick in to the usb flashback port with the mb off..push in the usb flahsback button and let the mb be updated. when done boot and hit f5 safe and exit then go back into the bios. set your dram speed to xmp profile. leave the first default video alone it should be ipg as default. under it will be intel sleep render..make sure that off the next line should be on if you want both the ipgpu and gpu on. when windows boots and it fine...download the intel cpu video drivers for the 4000/25000 for gen 3 cpu. the newest ones are for windows 7 and 8. both 32 and 64 bit drivers. install them and reboot. also make sure you have the newest intel chipset drivers installed.
m
0
l
a c 462 V Motherboard
September 11, 2012 3:35:22 AM

you need a mini hdmi cable on the mb video out port there no hdmi or vga on the sabertooth mb.
m
0
l
September 11, 2012 3:36:08 AM

Edit: Managed to fix the below. I will let you know how it goes. Thank you for the help!

I have plugged them both in and it boots, but I am still getting no graphics because I changed to iGPU from PCIE in the onboard graphics. So I can't see anything. I'm trying to get into bios and switch back to defaults in the darkness but it's not working. =/
m
0
l
September 11, 2012 3:38:31 AM

I got BIOS back (video from my GPU I'm guessing), and with all 8 prongs in it is still screeching. Red screen now. I will try your advice right now Smorizio, I appreciate your help.
m
0
l
September 11, 2012 3:39:57 AM

I'm running 1304 BIOS apparently, gonna get on top of it.
m
0
l
September 11, 2012 4:15:24 AM

Not working yet. I did everything you said in this order:

Cleared CMOS
Put BIOS back to default
Installed BIOS 1504 (showing properly installed)
Set DRAM to X.M.P. but didn't change anything after that
Switched off Intel Sleep Render
Left the 2 graphics options on Auto (which was default)


Still screeching and giving me different colored screens. That is as far as I have gotten. I will download the drivers on this PC and see if I have enough time to install them (I can boot windows, but the time before screeching varies). Will get back to you again. :( 
m
0
l
September 11, 2012 4:26:00 AM

It said my system did not meet the minimum requirements to install the Intel® HD Graphics Driver for Windows 7* 64

I'm going to see if I got the right ones? I did generation 3.

Edit: Sorry, guess I didn't grab the newest. In the process of installing. Will get back to you.
m
0
l
September 11, 2012 4:37:13 AM

No matter which drivers I install I still get the message "Your system does not meet the minimum requirements". I'm kind of stuck on what to do now. I'll try finding the newest chipset in the meantime.
m
0
l
September 11, 2012 5:05:01 AM

Completely at a loss now. I managed to install chipset drivers, but it still wouldn't let me do the VGA drivers (system req not met). I managed to install the newest NVIDIA drivers for my GTX 570, but it won't recognize it. I also tried setting in the BIOS to use PCIE as graphics and now I am back to pure black, can't see or do anything. Will have to navigate in the dark to get back to defaults.


If anyone can help me further I would really appreciate it. In the meantime I will try my GTX 460 and see if I have the same issues.
m
0
l
September 11, 2012 5:20:15 AM

Now on the "Starting WIndows" screen I am getting red & green dotted vertical lines (evenly spaced) moving up an down on my screen. 570 is still in, I have no idea what's causing it.
m
0
l
September 11, 2012 5:47:02 AM

Working perfectly with my GTX 460 installed (took out 570)

I am assuming it was the GPU and somehow it got messed up by putting it in my new pc? I was just playing Guild Wars 2 perfectly with it the past few weeks. Should I RMA it?
m
0
l
a c 462 V Motherboard
September 11, 2012 4:11:05 PM

sounds like something on the card died. iuf you want the onboard video to work on the sabertooth the last line under pci or ipeg (mvp ipeg video need to be set to enabled if not the onboard video will be turned off.) also on the sabertooth you need a mini hdmi cable.
m
0
l
!