Solved

Cannot connect PSU to ATX 12V Power Connector

I have an Asrock z77 extreme4 and a Rosewill green series 630 w psu. I've been trying for the past hour, but none of the cables seem to fit the power connector. Is there something off with it, or is the PSU just no good?
13 answers Last reply Best Answer
More about cannot connect power connector
  1. so all cables are not connecting properly or just one specific connector
  2. It's just that one specific connector. The 24 pin fits fine, and the gpu fits fine. However, the ATX 12v just won't fit with any of the plugs and cords on the PSU. It has 8 pins and the plugs at most only match 6 of the 8 pins, and after that, turning on the mobo doesn't even work. I am bread boarding all this if that helps
  3. use the 4 plus 4 pin

    1 x 4+4Pin ATX12V/EPS12V Connector


    for the cpu
  4. generalissimo said:
    use the 4 plus 4 pin

    1 x 4+4Pin ATX12V/EPS12V Connector


    for the cpu

    I tried that one. It didn't seem to match all of the pins. Only four out of the eight pins could be filled.
  5. http://imageshack.us/f/339/51303758.jpg/

    this is what the connector should look like, if you find it you have to merge the two to create the 8 pin and stick it into the cpu connector
  6. generalissimo said:
    http://imageshack.us/f/339/51303758.jpg/

    this is what the connector should look like, if you find it you have to merge the two to create the 8 pin and stick it into the cpu connector

    I know, but like I mentioned, four or those pins don't match the power connector. The one that only contains nonsquare pins does not match.
  7. so the other 4 won't go down into the connector or won't fit inside the connector
  8. Won't go down. As in, you can't plug them in at all.
  9. Best answer
    i heard this brand of power supplies has problems with the way they merge together so try playing around with the way it merges. If that does not work maybe you can get an adapter and see if it that will go in to figure out if its a problem with the psu cable. Otherwise do not turn it on without this connector as this will damage your mobo. Only use the EPS 12V CPU cable
  10. Managed to find the fix. Thanks for the help.
  11. Best answer selected by Blueyfooey.
  12. what was it
  13. One of the plugs was bent a little so it wouldn't fit. I used the other plug along the wires
Ask a new question

Read More

Motherboards Connection Power