Sign in with
Sign up | Sign in
Your question

ATI Radeon 5870 1GB Not rendering games

Last response: in Graphics & Displays
Share
July 4, 2011 9:05:24 AM

I've started buying some new games recently and in a few of them that I've installed my computer doesn't seem to be able to render the backgrounds and most objects in the games. the background is completely bluey/grey as are most objects, or they're just not there entirely.

I managed to get around it on Crysis 2 but just running the game in Windowed mode, and the game runs perfectly fine now and looks amazing, but for this other game I've installed, Darksiders, it doesn't seem to have a windowed mode so any help on how I could fix this would be greatly appreciated. I'd really rather not have to run all my games in windowed mode anyways.

It runs other games such as Borderlands, RIFT, WoW, EvE, Dragon Age 2, Fallout New Vegas, All CoD's completely fine.

Specs:
ATI HD5870 1GB
AMD Phenom(tm) II X6 1055T
750W PS
1920x1080
July 4, 2011 9:37:47 AM

i has the same problem but i has buy a better cooler en it was gone
July 4, 2011 9:43:10 AM

Why would a cooler have anything to do with something like this? my computer doesn't get hot at all...
Related resources
a b U Graphics card
July 4, 2011 10:29:27 AM

Doesn't sound like a heat issue, but a rendering one. Could use a bit more info...

What Catalyst driver version are you using, and what other versions have you tried? Darksiders got some driver love from AMD almost a year ago, so anything newer than 10.9a should run it smoothly and without error... Have you tried updating DirectX?
a c 106 U Graphics card
July 4, 2011 3:30:43 PM

Sounds like it's overheating or it's a driver issue. They go crazy when they overheat. Have you tried monitoring the temps while you're playing? Also, have you dried removing the drivers, using driver sweeper, and reinstalling the drivers? If you suspect heat, go to Catalyst Control Center, select the graphics tab, click "Enable Manual Fan Control", set the fan speed to "100%" and click "Apply". See if that helps your temps.
!