Sign in with
Sign up | Sign in
Your question

Mysterious black screen issue!!

Tags:
Last response: in CPUs
Share
December 6, 2011 8:08:17 AM

I recently finished a case mod: SG-PC over at OCAU.
I put the PC together fired it up, all went well.
About half hour into playing a game the screen went black and nothing worked.
I rebooted to find the black screen, no system beeps, no keyboard, nothing.
Here's where the story gets interesting...

After I pulled apart my system for the mod build I noticed my CPU had a pin missing; so I examined the
socket carefully and could not find any evidence of the missing pin.
I bought another CPU (same s939 AMD X2 4800+) ready for the new build, and as I stated at the top
it started fine then went to black screen and stayed that way - no system beeps what so ever, with or
without RAM.

I have since tested every component, on it's own, and in a different working system, to find no possibilties of faulty hardware other than mobo or CPU.
Now, I tried another spare (previously working s939 FX57) CPU in this mobo, but same result!?

I have determined that the mobo must be at fault so I have bought another.
I put in different known working RAM, different known working PSU, as well as diff GPU, just to eliminate
any other possible faults ( also diff monitor and cables!!!); no hdds or other peripherals, just CPU, GPU and RAM. Guess what - exact same scenario: black screen no system beeps or keyboard activity. WTF?!!!
Could I really have fried all 3 CPU's in the old mobo or is the new mobo dead or what?

Any help here is appreciated as I've spent 10 months on this thing and don't wanna buy yet 'ANOTHER"
CPU until I'm sure of the problem.

Cheers. :heink: 
a b à CPUs
December 6, 2011 8:31:19 AM

It sounds to me like you have an electrical short in your case somewhere that is either frying components or preventing the PSU from functioning. Another possibility is that an external device attached by USB 2.0 most likely that is tripping your system up. This can be especially true if the device is self powered.
m
0
l
December 6, 2011 9:03:39 AM

Thank for replying:

I forgot to mention that with the new mobo, I set up a test bench outside of the case,
I checked for grounding/ short circuits and fitted everything delicately with a anti-static wrist strap,
but still no good - unless of course a short in the modded case killed all my CPU's, hence not working
in the test bench either.

I'm gonna get another cheapo CPU to test the new mobo config on the test bench, if that works
I'll do a full diagnostic of the SG-PC to see if there are any shorts.
m
0
l
!