New build, unverified compatibility, no sign of life

Is this description relatively common on desktop computers? (Press power button, nothing happens, no concerning sounds or PSU fan)

Tried so far:
Tried both sides of F_PANEL power button connector
Ensured ATX cable secured as well as CPU power
Video card properly seated
Memory properly seated (DIMM_1 & DIMM_2)
Power cable properly inserted
CPU installed as instructed by manual

I am creating a 'new' computer build while reusing my older PSU and Antec case (which was fully functional as of yesterday [BFG Tech 650W])

Spec
Kingston KHX1600C9D3B1K2/8GX
Gigabyte GA-Z77-D3H Rev 1.0
4 answers Last reply
More about build unverified compatibility sign life
  1. Did you flip the PSU switch to on?
  2. Engima said:
    Did you flip the PSU switch to on?

    Uhh yeah.
  3. I would still double check the connections with your front panel according to the manual. It should at least light something up on your motherboard if you pushed the power switch.
  4. Just to follow up on this topic... I fixed it the day after and it was one of the few things I did

    - Re-seated motherboard
    - Made a match to all of the screws for the "case grounds" I had previously
    - Loosened the motherboard screws a bit
    - Did some minor air cleaning of the internals of the PSU (quite a lot of dust built up there!)


    Finally showed signs of power after this with a Jerking ON... and OFF every 2 or so seconds. After about the 5th restart like that (no post no CPU fan) the CPU fan kicked in and kept on going. POST showed my motherboard had a corrupted BIOS (simply replaced itself with the secondary-backup BIOS).

    Would consistently have that 'power jerking' effect on a COLD boot of my computer. I believe I fixed it by turning off all of the preset SMART FAN settings.

    Have seen no problems since. Thanks for the help.


    Edit: Although this RAM is not on the QVL for this motherboard. It works GREAT so far with no issues.
Ask a new question

Read More

Memory Power