Sign in with
Sign up | Sign in
Your question

Please Help sabertooth z77 issue

Tags:
  • Motherboards
  • Sabertooth
Last response: in Motherboards
Share
September 13, 2012 9:52:05 PM

Hello!
I have a problem with my computer. Basically when i press start button it loads to a sabertooth logo and than restarts. and keeps doing that in the endless loop. All leds on my mobo flash red one after another. This happened a week ago and i got a replacement motherboard. this replacement seems to have the same issue.
My specs are:
Sabertooth z77
3770k
680 classified
32gb ram corsair vengence (tried using 8gb but didnt work)
corsair ax1200i
also i had a corsair h100 cooling the cpu but when i installed everything on a new motherboard some smoke came out from the waterblock/pump and I kept getting the cpu fan error.(so i guess the h100 died) Currently i have a stock intel cpu fan installed. I have tried clearing Cmos using the jumper a few times but still cant boot even into bios. The logo that i am stuck at at the bottom says press del to enter bios, but i cant because the keyboard doesnt power on. I dont think I have a problem with the PSU as it has power on self check wich i have tried a few times and the led is green, so i think it is working properly. I checked all the motherboard connectors like 100 time now.
Please help. Sorry for bad english.
:cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry: 

More about : sabertooth z77 issue

a b V Motherboard
September 14, 2012 4:33:20 PM

While it's not impossible to get a replacement board with the same problem, the odds of that happening are so remote they may as well be impossible. So if you get a replacement component and the problems persist, then that component wasn't the source of the problem.

In cases like this, the first thing you should do is break it down to the bare essentials. Only what you need for the unit to POST. Bare minimum RAM, CPU, PSU, that's it. If you get it to POST successfully, then you can start adding components in one by one, testing each time you add a component, until either everything works or you find the problem component.
m
0
l
a b V Motherboard
September 15, 2012 8:09:02 AM

I also believe your ram is not on the QVL for the motherboard therefore it may not be compatible. Try another stick of DDR3 ram from a friend if possible and see if it boots.
Updating the bios to the latest version may help with compatibility issues.
Go to Asus.com and get the latest bios and flash it with a USB, the instructions should also be there.
m
0
l
!