Solved

Good Video Card But Games Lag

Specs:
i5 2500k@4.5ghz
Sapphire Radeon HD 6950 2gb(Unlocked Shaders with Modded Bios)
Asrock P67 Extreme4
G. Skill Sniper 8gb@1600mhz
Corsair AX750 watt

Hi, whenever i play games the cut scenes are laggy and i'm not maxing out the game. It's only the cut scenes and never the gameplay itself. I know if it's just the cut scenes it doesn't affect the way i play, but its annoying for me and i would expect that a 300 dollar video card would run games pretty well. Multiple games are like this like Shogun 2, BFBC2, Medal of Honor, Assassin's Creed Brotherhood, etc. So basically i want to know it its my card or its the game.
10 answers Last reply Best Answer
More about good video card games
  1. cut scenes are laggy? can you be more specific? get FRAPS and monitor the FPS, tell us what FPS you are getting when its "laggy". Also, try putting the vid card back to the original BIOS, remove the overclock from your CPU and see if its still laggy. Make sure you have the motherboards latest BIOS and latest drivers for the vid card installed. Defrag the hard drive too. then get back to us once you have done all this.
  2. What are 'cut scenes', anyway?
  3. sdm5 said:
    Specs:
    i5 2500k@4.5ghz
    Sapphire Radeon HD 6950 2gb(Unlocked Shaders with Modded Bios)
    Asrock P67 Extreme4
    G. Skill Sniper 8gb@1600mhz
    Corsair AX750 watt

    Hi, whenever i play games the cut scenes are laggy and i'm not maxing out the game. It's only the cut scenes and never the gameplay itself. I know if it's just the cut scenes it doesn't affect the way i play, but its annoying for me and i would expect that a 300 dollar video card would run games pretty well. Multiple games are like this like Shogun 2, BFBC2, Medal of Honor, Assassin's Creed Brotherhood, etc. So basically i want to know it its my card or its the game.

    I experienced the same problem with my own 6950 when playing Prototype. If you have not done so, disable "Morphological Filtering" in catalyst.
  4. sdm5 said:
    Specs:
    i5 2500k@4.5ghz
    Sapphire Radeon HD 6950 2gb(Unlocked Shaders with Modded Bios)
    Asrock P67 Extreme4
    G. Skill Sniper 8gb@1600mhz
    Corsair AX750 watt

    Hi, whenever i play games the cut scenes are laggy and i'm not maxing out the game. It's only the cut scenes and never the gameplay itself. I know if it's just the cut scenes it doesn't affect the way i play, but its annoying for me and i would expect that a 300 dollar video card would run games pretty well. Multiple games are like this like Shogun 2, BFBC2, Medal of Honor, Assassin's Creed Brotherhood, etc. So basically i want to know it its my card or its the game.


    Fist off, there is no need to overclock your cpu at all with a single video card. It's just a waste of heat and electricity.

    Likely your problem is either an unstable cpu overclock or unstable gpu overclock.

    Still trying to figure out what a "cut scene" is.

    My Q6600 and 5850 maxed BFBC2 flawlessly at 100fps.
  5. geekapproved said:


    Still trying to figure out what a "cut scene" is.



    Mini movie type thing that is pre-rendered that plays in the game. Like in WoW during some quests and dungeon finishes.

    http://www.google.com/#q=wow+cutscenes&hl=en&prmd=ivns&source=lnms&tbm=vid&ei=QmgUTqb_M8PogQe5rJH-BA&sa=X&oi=mode_link&ct=mode&cd=3&sqi=2&ved=0CAkQ_AUoAg&bav=on.2,or.r_gc.r_pw.&fp=32776dff79dd001a&biw=1280&bih=915
  6. iam2thecrowe said:
    cut scenes are laggy? can you be more specific? get FRAPS and monitor the FPS, tell us what FPS you are getting when its "laggy". Also, try putting the vid card back to the original BIOS, remove the overclock from your CPU and see if its still laggy. Make sure you have the motherboards latest BIOS and latest drivers for the vid card installed. Defrag the hard drive too. then get back to us once you have done all this.



    I got fraps and i my FPS is around 80 when i play BFBC2. I tried changing the bios of my video card back and same problem. I also removed the overclock and same thing. I have the lastest bios and drivers and i frequently defragment my hard drive. Only the cutscenes lag. It's fine for a while but when theres people moving or a lot of action it gets a little choppy.
  7. randomkid said:
    I experienced the same problem with my own 6950 when playing Prototype. If you have not done so, disable "Morphological Filtering" in catalyst.


    When i went to CCC, Morphological Filtering was already off.
  8. Best answer
    have you tried playing around with vsync settings?
  9. Best answer selected by sdm5.
  10. iam2thecrowe said:
    have you tried playing around with vsync settings?


    Thank you very much. I turned vsync on in all my games and there is no more tearing.
Ask a new question

Read More

Graphics Cards Games Graphics