Sign in with
Sign up | Sign in
Your question

No display/ post problem

Last response: in Motherboards
Share
September 16, 2012 7:01:12 PM

Hello forum..

I keep encountering a problem with motherboard 'sabertooth z777'. I have tried nearly everything but still the same problem occurs. I have tried:

- Making sure standoffs are placed.
- Trying another GPU
- Trying motherboard outside case.

I dont see how can the problem be fixed? Is it a HDD failure?

The Boot LED lights up solid red.. and the other leds light up simultaneously until staying on boot LED.

I dont think the problem can be fixed..

what do you think?

More about : display post problem

September 16, 2012 7:09:53 PM

Does your manual say anything about a red LED on the motherboard? I don't know of many normal situations that would show a red color LED.
a c 471 V Motherboard
September 16, 2012 7:18:04 PM

depending on your cpu and ram and the mb bios it may or may not post. first off see if there a bios sticker on the mb to see what bios is on the mb. if there non start with the newest bios 1504. use the usb flash back port and rename the bios file z77st.cap put it on a fat32 usb stick into the white flashback port. with power supply off(in standby mode). press the flashback button and hold for a few seconds..it should start blinking...if the file is named right...the bios flashback light blink speed and pattern will change. when done the light will go out.; if the newest flash does not fix memory issue. check that the cpu cooler not screwed in to hard and bending the mb or cpu. also check that you have the 4/8 pin atx power plug near the top of the mb connected. if it is try unplugging the hard drive and cd-rom sata cables from the mb. there are two sata chipsets the intel ones and a 3party chipset if you put the hard drive and cd-rom into the wrong ones the mb may not post. also to degug your system pull the video card and use one ram dimm...i seen here and on rog where the mb has had dead ram slots. with 2 or more dimms in a bad dimm slot it wont post. last thing to check is bent pin on the mb under the cpu or the cpu not seated.
Related resources
a c 471 V Motherboard
September 16, 2012 7:19:13 PM

the red led on the mb one of them is ram led..it blink red at power up. if it soild then there an issue.
September 16, 2012 10:57:13 PM

thanks smorizio. I have done the USB flash-bios, I have unplugged the sata cables (1 long 4 short.. still continues to beep).

Could it be bad wattage cpu cooler? because it starts 5 seconds late.
a c 471 V Motherboard
September 16, 2012 11:37:27 PM

two things bad ram or ram that not been tested for that mb or the z77 chipset. see if it 1.5v ddr-3 ram. also check to see if it 1600 or slower ram. most 1600 ram should work. take a look at your video card make sure if it has two 6 pin pci that there both plugged in. with the ram clips on the sabertooth they take a little force to make sure then down and locked. i would use one dimm and the gpu and no other cards to see if you can get it to post. if you have another ps that rule out the power supply.
also what the model of the cpu. with new mb it called anti surge where there a small delay on cpu and case fans. it normal for the stock intel or aftermarket fan to spin up a few seconds after the on button is pressed.
September 16, 2012 11:52:56 PM

ram is 1600mhz. applied force to ram and gpu.. i still get a beep 1 long 4 short and boot led constant.
a c 471 V Motherboard
September 17, 2012 3:00:04 AM

is the 4/8 pin white atx cable plugged in. in on the top back edge of the mb.
http://usa.asus.com/websites/Global/products/wMYmwl5uuG...
the 8 pin connector on the edge of the mb near the mb standoff screw and asus logo.
check that the video card in the top video slot...also try it in the lower one. i would also try another video card .
September 17, 2012 10:25:40 PM

same ******* problem... all leds light up.

why are asus motherboards unreliable?
September 17, 2012 10:33:17 PM

Could it be a faulty CPU? I tried another GPU and still 1 long 4 short.

Its either.. CPU,CPU Fan,Motherboard
September 18, 2012 2:08:59 PM

What do you suggest?
September 18, 2012 11:38:51 PM

its obviously a hardware failure. because its 1 long 4 short beep, is it the motherboard or CPU?
a c 471 V Motherboard
September 19, 2012 9:22:14 PM

i would check for under cpu for bent pins or thermal paste on the pins. also check that the cpu is hitting all of the cpu pads. if there no issue i replace the mb first then the cpu.
September 25, 2012 2:28:46 PM

No bent pins. Thermal paste is there.
September 25, 2012 2:28:49 PM

All I am getting is now 1 short boot beep.. and then LED lights on all RAM,GPU,BOOT.

Asus motherboards are bad
September 25, 2012 2:50:57 PM

im not getting any beeps now. Im just getting error leds on an asus motherboard. After I changed.. the CPU cooler the 1 long 4 short beeps went.

So im thinking its either the CPU Or motherboard. Most likely CPU? because i tried another motherboard and the same problem occurred.

Its either: 1. CPU 2. PSU
October 14, 2012 10:23:17 PM

Same problem still happening. It's not the motherboard because I tried multiple, it's not the GPU because I tried multiple. The problem still happens when I turn the computer on I get 1 post beep and then LED's light up in all places.. not giving an accurate cause of the problem. I have gone through the troubleshooting guide, and have tried multiple RAM and tested the motherboard out of the case.

I have no idea what this could be, can someone give a clear explanation of this problem and what could be causing this so it can be fixed NOW... it has taken ages to actually find the cause of the problem.
!