Sign in with
Sign up | Sign in
Your question

USB 3.0 20-1 header limitations?

Last response: in Motherboards
Share
September 17, 2012 6:47:24 AM

I've got a new Z77 Extreme 4 in my build and everything works perfectly with the possible exception of the USB3_34 header. I have a 3.0 Seagate Backup Plus Portable that I know works perfectly from tests on friends machines and other ports on this build, but it is very unstable on my front ports. It will run for some time under low data transfer but if I leave it running to long or I transfer a large folder it stops working. Sometimes Windows complains it can't find some of the files and other times the copy goes very fast and ends up having only the folders and a few random files instead of the entire copy. Every time it fails the led on the drive turns off.

The ports themselves run fine with other USB 2.0 devices, but unfortunately I don't have another 3.0 device on hand to test with.

I'm pretty sure it's a power issue since all the symptoms seem to fit. ASRock support suggested a new cable and so I'm waiting on one from Rosewill (who by the way has awesome support) and I've ordered a small adapter to make sure cable length isn't the issue. I'm pretty sure the cable was fine though considering both of the splits exhibited the same symptoms and USB is rated to 5 meters so unless the whole cable batch was screwy I think that's a dead end.

I've been scouring forums for about a week but I can't seem to find anything.

The notion I'm entertaining at the moment is that either the board is not supplying enough power to the header or that the header isn't specd to supply the same amount of power as a normal 3.0 port. Does anyone with some data sheet skills have any idea if that might be the case?

More about : usb header limitations

a c 121 V Motherboard
September 17, 2012 2:57:25 PM

It definitely sounds like the board is not supplying enough power to the USB header, and to be honest portable drives have always been a sore spot for me, since they do tend to get pretty close to the power draw limits designed for USB.

I know one of my portable drives has a "split" end where I can plug it into 2 ports on the computer to augment the power (http://www.notebookcheck.net/typo3temp/pics/4719a3a984....) Getting something like that can definitely help.


Another way to check to see if it is just a power issue is try using one of the 3.0 ports on the back of your machine, built into the MB, since there should be no power issue there.
m
0
l
September 17, 2012 3:25:24 PM

Yeah sorry I should have been more clear, I have checked it on the back ports on my computer and it does work. That was one of the reasons I thought it was a power issue.
m
0
l
Related resources
a b V Motherboard
September 17, 2012 8:38:45 PM

USB 2.0 is rated for 5 meters USB 3.0 is rated for 3 meters. so you have to figure in the cable length from the motherboard to the front case port plus the extension cable you are going to use.
m
0
l
September 17, 2012 8:44:03 PM

I'm at around 1.5 meters total. Probably a bit under. Maybe because of the split I have to double it? I dunno, just shooting in the dark.
m
0
l
a c 120 V Motherboard
September 17, 2012 8:58:28 PM

I am posting here to see what solution you come up with. My USB3 front ports have never worked right either(Maximus IV Gene-Z). Had 2 cables with similar disconnection issues of my flash drive.
m
0
l
a c 120 V Motherboard
September 18, 2012 3:21:27 AM

This specification defines only the form, fit, and function of the cable assembly. Thus, the specific cable
construction is up to each connector and cable assembly manufacturer. The following cable
requirements and/or guidelines apply:
-The maximum cable assembly length shall not exceed 457.2 mm (18”). For most small form factor
systems, a 12” is recommended.
-To ensure the cable flexibility, the cable shall be able to be bent to a radius less than 25.4 mm (1.0”).
-The raw cable impedance should be managed to be within 90+/-7 ohms.

Mine(20-pin to case usb3) is longer then that for sure.
m
0
l
September 18, 2012 7:21:54 AM

Well damn so is mine.

I should be getting a little adapter in that can't be more than 2 inches long by Friday at the latest. I'll try that one out and let you guys know.

I know it isn't such a big deal but I get a little twitch everytime something in my build doesn't work.
m
0
l
a c 120 V Motherboard
September 18, 2012 4:30:37 PM

I have a short adapter(Ngear brand), it was the first thing I picked up but for some reason it did not work with my cases pass-thru cable setup(but if i connect my hardware to it directly it works just fine. The case pass-thru cable works find connected to the rear ports as well), so I ordered the proper 20-pin cable from the company(assuming a hardware compatibility issue) and it did not work any better. I am on my second one now.
m
0
l
September 18, 2012 8:18:01 PM

So if I'm understanding you:
Cable Length:-----------------------------------------------Works?:
Long 20 pin adapter------------------------------------------No
Small 20 pin adapter-----------------------------------------Yes
Small 20 pin adapter + Pass through cable--------------No
Pass through cable-------------------------------------------Yes

Correct me if I'm wrong but from what you're saying it sounds like cable length is exactly the issue. Looks like the total cable impedance should be 83-97 ohms and since it looks like my inside cable is 2 or 3 times the maximum recommended length it stands to reason that I would have 2 or 3 times the maximum rated resistance. More resistance means more voltage drop across the cable and less power delivered thus causing the problem.

I have access to some electronics equipment but I'm not around it at the moment. I'll take it in and poke around.
m
0
l
a c 120 V Motherboard
September 18, 2012 8:34:47 PM

Please post your results.

I find it hard to believe that a cable should have so much resistance to begin with, but maybe it has to.

Strange this is ONE of the 2 front ports seems to work. The other one just randomly says screw you I am disconnecting. I have routed this cable far from everything else in the case too.

My short adapter + pass cable are shorter then the recommended as well.

The 20-pin is just very long for nothing, but i can see a bigger case could use it maybe?

I could see if 20-pin + usb3 cable to BD player caused issues, but with the flash drive, it has no cable.

With all this, I am glad i stuck to e-sata for my backup drive.
m
0
l
September 18, 2012 9:13:45 PM

I was just looking at the raw cable impedance. Maybe I'm reading that incorrectly.
m
0
l
a c 120 V Motherboard
September 19, 2012 1:04:15 AM

i see the same thing. May be like coaxial's 75 ohm thing. I do not think its the cable, but the device it connects to.

I have swapped my BD reader for a hard drive so I can do some more tests. With a brand new 3 foot cable.

Something interesting. One of the onboard ports was doing a connect disconnect all the time. So I place the pass-thru cable in and it worked perfect. Then went back to the board, disconnect reconnect again and again(I had tried replugging it and it was very unstable). Then it just stopped doing it and started to work perfect(it does not matter what I do to the cable it was just working. I have no clue why this would happen.).

I am starting to think that some USB3 controllers(or the makers of the plugs/cables) are just not ready for prime time or something.

I have 2 other USB3(Old NEC and Renesas[based on NEC as far as I know]) boards to test with and see how they react.

I have tried that plug over and over and now both back plugs work perfect.

On to the 20-pin long cables.

It cant get any worse. connect/disconnect over and over again.

The battle goes on.

I did a quick meter of resistance on one of the cables(but only 2 pins. this plug does not follow the size of any headers i have access to.) and came up with nothing to report.
m
0
l
September 20, 2012 3:24:46 AM

My resistances all came out to be between .15 and .3 ohms. Not what we thought it was specd to be but not suprising.
m
0
l
September 20, 2012 4:13:48 AM

Ok I've been reading over some standard sheets for USB 3.0 and as far as I can see this port should be standards compliant so I'm not sure why it isn't supplying enough power.
I'm starting to wonder if it isn't this particular hard drives fault. Seagate told me:
"In most cases the back USB ports are more stable then the front USB ports. The back USB ports are connected to the motherboard. The front USB port are mainly meant to be used to small flash drivers, cameras and smart phones, not external drives."
Which is just not true, or at least it shouldn't be. A standard compliant port should be able to supply enough power regardless. I'm still going to test with the small adapter when I get it and I'll report back.
m
0
l
a c 120 V Motherboard
September 20, 2012 4:32:31 AM

Not one but, What was the resistance of your meter leads? mine was just the same as the cables so unless my old fluke is failing, resistance is not an issue.

I would almost need to buy usb ports from digikey or something and then setup a test to see how sensitive the actual connections are.

I do not personally like the idea of the offset plug style because if the plug is not in all the way, chances are you will loose the extra send -|+ | ground rec | - | +

But in my tests even serious cable movements do not effect the connection, but some plugs seem to have just slightly longer 3.0 contacts at the front(female plug).

At first the thought it was that, but it does not seem to be so.

On a more interesting note. 1 of my motherboards headers intermittently drops my external BD case with a hard drive in it. I am using a hard drive because I can force very long benchmarks to keep the USB ports active for testing.

It is very strange.
Boot up connect the drive it works
Push about 600 gigs to it(300 each way). good all is well. I was also playing with the cable and plug lots to make sure the contact was solid even if the cable moves. It worked no matter how much I moved the plug, so I tend to rule out a physical issue.
Power cycle the drive(only did it to see if it was that damn fan that was soo loud, so will be replacing that fan in the future maybe). connect/disconnect over and over.
Add in a short extension cable(testing for a contact issue). it works.
Remove the cable, still work. WTF

I have tested the drive/enclosure on another system with no issues.

I am having more and more issues with USB 3.0 then it seems to be worth. I will be contacting Asus to see if they have any suggestions. This is all on top of the 2 SilverStone kits that do not work quite right on the 20-pin header(hard to keep requesting new cables if they will never work due to some kind of length issue).

Almost willing to try this with the stock case cables, but its not a solution to the problem.

USB 3.0 should be much better at either throttling if the connection is unstable(Same way wireless 802.11A/B/G/N do). I would much rather drop to 2-4gigabit(and that is more then enough for me) then drop off all together(hell go to USB2 speeds at least then my file transfers do not fail.).

I am kind of glad I did not go too USB3 crazy because this seems to be quite an issue.

A quick Google gives you lots of people with USB issues on both front and back ports.
m
0
l
a c 120 V Motherboard
September 20, 2012 4:38:34 AM

gitbox said:
Ok I've been reading over some standard sheets for USB 3.0 and as far as I can see this port should be standards compliant so I'm not sure why it isn't supplying enough power.
I'm starting to wonder if it isn't this particular hard drives fault. Seagate told me:
"In most cases the back USB ports are more stable then the front USB ports. The back USB ports are connected to the motherboard. The front USB port are mainly meant to be used to small flash drivers, cameras and smart phones, not external drives."
Which is just not true, or at least it shouldn't be. A standard compliant port should be able to supply enough power regardless. I'm still going to test with the small adapter when I get it and I'll report back.

USB3 should have enough power to start-up most 2.5 inch drives.

USB2 had a limit of 500ma(I think its something like 900 for USB3) and that did cause problems for some users, This the 2 cable systems some drives come with(Items like this use USB3 for data + power and a USB2 port for the rest of the power http://www.alibaba.com/product-gs/558191617/Bizlink_USB...). I know my H55N USB3 board will not power a USB 2.5 inch drive from its from ports(the drive needs more then the 500ma given to get spinning). On the other hand I have many Asus boards that will let me pull 1.5 - 2 amps from the front ports(I even ran an XM radio receiver from a USB port when I had no power adapter.). How safe is it? Not sure, but it did :) 

When ever a hard drive was hard to power up, I could here it try to spin then stop when listening close to the drive.
m
0
l
September 21, 2012 4:55:31 PM

Ok so I officially have an RMA from ASRock. I noticed that I can't see any of my devices pulling current in my device manager usb hubs. I'm thinking this just might be a board mishap. If after further testing the thing still craps out I'll send it in.

Still haven't gotten my tiny header in so no testing there so far but rest assured I'll report back.
m
0
l
a c 120 V Motherboard
September 21, 2012 5:09:20 PM

Ok. I am still talking with Asus and trying to source my self another board(Why must all my friends not have USB3 20-pin boards :(  ) to test my SilverStone FP cables to see if it is the length of the cables or just a bad board too.

So far Asus is quite quick with e-mail replies.
m
0
l
September 22, 2012 5:07:13 AM

OK I figured out my problem. I got in my new cable and small adapter. I tried the new cable first and it exhibited the same symptoms as the last one so I pulled it off. Then I attached the tiny header and boom it works perfectly. I couldn't get this thing to fail. The header was fine and so was the drive so I don't have to return the board. Now I'll be looking for a way to fit my case with different cables because apparently the crap ones Rosewill provided are either to long or made incorrectly. Thanks for the discussion and help and best of luck solving your problem.
m
0
l
a c 120 V Motherboard
September 22, 2012 9:19:00 PM

See if Rosewill can send you some new cables.
m
0
l
September 23, 2012 1:19:27 AM

I will ask them about some shorter ones, but the problem actually seems to lie with Rosewill or their cable manufacturer SanDian. If they have the same cable but 18", instead of the 35" cables I now have 2 of, I'd take a look at it.

I pulled one of the cables apart and it looked pretty well manufactured. The resistance measurements I mentioned earlier support that.

Since I know now that I have a working motherboard and drive and that the cable that didn't work was physically sound, I have to think that the extra length created some sort of crosstalk between the different strands that caused my problem. That would explain the failure during data transfer.
m
0
l
a c 120 V Motherboard
September 23, 2012 3:28:04 AM

I would guess something similar. I have 2 from SilverStone with similar issues. I was thinking about isolating them some how, but it seems like lots of work for a flash drive that can get 40 megs a sec on USB2(on the USB3 controller in USB2 mode). This ASmedia is the FASTEST usb2 device I have had for sure(so it has an advantage even in USB2 mode).

Its more about if USB3 is that sensitive because I wanted to get 6 foot cables for future uses, but if it has that much issues with internal cables, how will the outside ones fair.
m
0
l
a c 120 V Motherboard
October 5, 2012 7:17:13 PM

Just an update, got another 20-pin to usb port adapter figuring worse case, at least then i would get access to the ports on the back.

The non LP version of this.

http://ca.startech.com/Cables/USB-3.0/2-Port-USB-3-A-Fe...

Still in testing, but not soo good so far(seems to drop at random). Yet my 6 foot cable on the short N-gear 20 pin adapter does seem to work, but needs more testing.

Also got my self a 6 foot cable for my drive + a 6 foot extension cable for testing.

So far.

H55N USB3 with rear Renesas ports board will work with cables up to about 6 feet. After that speeds fall off, but it does not drop and connect.

Maximus IV Gene-Z. Anything over 6.5 feet just does not work and drops ect. This does not seem like it will be good for front port cables as they eat space, but time will tell. Maybe its a defect after all.

X58A UD5 with just rear NEC ports. I have just started to test this boards USB3 ports. So far it is very good. 6 + 6 cable runs just fine without any kind of drops. 6 + 3 did not seem to work quite as well on other boards and fails on my Maximus IV Gene-Z

Quite a range of quality issues related to USB 3.0 from what I can see.

Kind of concerned to RMA a board to have the same issue again.
m
0
l
!