Sign in with
Sign up | Sign in
Your question

Random Frame drops.Not sure if its the computer acting up or the game.

Last response: in Systems
Share
September 9, 2011 2:41:17 AM

Ever since i built this computer i have had some difficulties with it. Games play pretty well, but pretty much all of them would get a really bad lag spike.

here are my specs


AMD Phenom II X4 840 3.2GHz
G.SKILL Ripjaws X Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600
MSI 880GM-E41 AM3 AMD 880G HDMI Micro ATX AMD Motherboard
HITACHI HDS721050CLA362 (0F10381) 500GB 7200 RPM 16MB Cache
Seagate Barracuda ES ST3750640NS 750GB 7200 RPM
ASUS EAH6950 DCII//9not overclocked)
Ultra U12-40873 LSX 650-Watt Power Supply
LG cd burner.


Now, could it be that some of the parts just Aren't working right together?

Games that do it on the most lately are:
BFBC2
Dues Ex
Dead Island
Metro 2033
Borderlands
Oblivion
Section 8: Prejudice
Homefront

Let me know what i should look for and or if i should get some new better parts.

Almost forgot, i even turn the settings down in the game and it would still happen. Not as bad, but still annoying.

Thanks!
a c 113 B Homebuilt system
September 9, 2011 7:45:33 AM

Could you be more specific than "pretty much all of them would get a really bad lag spike. "?

What does that mean? How frequent is this spike? Since it occurs in games with no internet connection needed it really isn't "lag" so what is it? frame rate drops? brief game freezes?

As a side note, the standby power circuit of the 750W model of that series of PSUs failed testing badly... a possible issue I wanted to note before I forgot.
m
0
l
September 9, 2011 1:40:23 PM

Sorry about that. The frame rate drops. Really not sure why said lag spike....
It happens usually when something is loading, like textures and what not. I know dead island was a little buggy when it came out, but i had everything se to high. Getting over 100 FPS. When i would be running around, the Frame rate would drop down to the 70's then 60's and you could really tell that it was alot worse. Then i put everything on medium. Still getting the same frame rate, but a little smoother. It would still do it tho.

I know my computer isnt a "beast" but it should be able to cut through this game. Atleast i thought it would be able to.

The power supply. Could that be the culprit? It was pretty cheap when i bought it (on sale)

m
0
l
a c 113 B Homebuilt system
September 9, 2011 5:37:21 PM

Grab HWMonitor and check your temps under load. Use Prime95 to stress the CPU and Furmark or such to stress the GPU. You can also get a kind of benchmark from software like Passmark
http://www.passmark.com/download/pt_download.htm

Your processor and GPU definitely should be up to the task. I suspect something more like RAM or HDD issues, but get the preliminaries done first.
m
0
l
!