Sign in with
Sign up | Sign in
Your question

Asus Xonar D1 problem

Tags:
  • Sound Cards
  • Components
Last response: in Components
Share
December 10, 2011 7:57:21 PM

Hi everybody, I'm new to these forums and computer building in general. Recently i've ran into my first problem and I thought this was the right place to ask a question. When I first bought my pc I was using my motherboards onboard audio connected to my reciever through optical out which was fine for the time being, but it only output in stereo. Last week I bought a Xonar D1 because it seemed to have some good reviews and I thought it would solve my non surround sound output problem but it didn't. I have downloaded the latest drivers from the asus website and messed around with the software it comes with and have not been able to produce a solution. Basically, my reciever doesnt recognise whatever signal my soundcard pushes to it, although if I go into sound settings and test my encoded formats it outputs 5.1 sound fine in dolby digital. Oh, and my uses for this card are purely gaming. (BF3, MW3, etc.) Hopefully this makes sense, any help would be appriciated!

Motherboard- http://www.asus.com/Motherboards/Intel_Socket_1155/P8P6...
Reciever- http://www.google.ca/#hl=en&cp=15&gs_id=1n&xhr=t&q=Yama...
Soundcard- http://ncix.com/products/?sku=39269&vpn=Xonar%20D1&manu...

More about : asus xonar problem

Anonymous
December 11, 2011 1:12:28 AM

Well your onboard realtek should have worked fine from the start.

Realtek® ALC 889 8-Channel High Definition Audio CODEC
- Supports : Jack-detection, Multi-streaming, Front Panel Jack-retasking
Audio Feature :
- Absolute Pitch 192kHz/ 24-bit True BD Lossless Sound
- Blu-ray audio layer Content Protection
- DTS Surround Sensation UltraPC
- Coaxial and Optical S/PDIF out ports at back panel

"Basically, my reciever doesnt recognise whatever signal my soundcard pushes to it, although if I go into sound settings and test my encoded formats it outputs 5.1 sound fine in dolby digital."

I dont seem to understand how it works and doesn't. Which sound settings? How do you test your encoded formats? Outputs from what to what?
m
0
l
December 11, 2011 4:33:14 PM

I thought that taking a few pictures would help me explain my problem- http://imgur.com/a/2KAO5 (hopefully that link works, im new to imgur!)

First picture- The screen that I use to test my sound, control panel-> hardware and sound-> sound. All you have to do is highlight the format you want to test, click test, and it sends a tone to each speaker.

Second picture- What my reciever looks like outputing standard stereo sound. This is how it looks all the time when using my pc.

Third picture- What my reciever should look like. Outputing surround sound to all channels, as seen on the right of the display.

Fourth picture- Same thing as the third picture just testing in DTS.
m
0
l
Related resources
December 11, 2011 4:58:16 PM

Your problem is not your soundcard, but the type of signal you are trying to play.
The Xonar D1 is Dolby Digital Live certified, that means it can generate a Dolby Digital/DTS Signal and not just play one. Your onboard soundcard could decode/play DD fine, but it could not generate it.
Check your settings (especially the ASUS driver) for "Dolby Digital Live" and choose 5.1 for your speaker setup.
Some games also have this option in their audio settings.
m
0
l
December 11, 2011 5:15:46 PM

http://imgur.com/a/ZQjXn I think I have both of those options selected, i'm not to familiar with the asus software.
m
0
l
December 11, 2011 5:42:03 PM

untick the Dolby Pro Logic box. If your speaker setup isn't 7.1 you don't need it.

The fact that channel testing in windows seems to work tells me that the problem has to be the signal source, i.e. the software that is producing the sound.
m
0
l
December 11, 2011 6:43:49 PM

I'm thinking the same thing, do you have something that I can test this with? like a video/application that is known to output 5.1 surround sound?
m
0
l
December 11, 2011 9:03:53 PM

When you hit the "test" button in the windows sound settings you are able to hear all channels?
Also make sure your SPDIF is active but NOT set to "passthrough".

Right now i cannot think of a program with guaranteed 5.1 output, other than maybe some demo/test program by ASUS or Creative. But if the windows sound settings test button produces sound on all channels the problem can only be the game. Have you testet multiple games, or just MW3?
m
0
l
December 11, 2011 9:09:43 PM

I just found something on the ASUS D2x forums, but the title says it applies to all Xonar soundcards.
click me hard
m
0
l
December 12, 2011 12:29:39 AM

Yes, I can hear all channels perfectly when doing the windows test.
How would I go about checking if my SPDIF is set to passthrough?
That link had a lot of valueable info on it. Seems like that may be a possible solution but I cant find the option to set my input to multi channel, any idea how I set that?
explained in this line "Then you open the "Xonar Audio Center" tray icon by clicking it, and setting the input to any of the multi-channel input (depending on how many sound channels is produced from what you are doing [gaming, movies, etc.]). And set the SPDIF OUT on to DTS or DD."
m
0
l
December 12, 2011 12:41:06 AM

oh! I forgot to mention, I have tried it with other games. I'm just playing MW3 right now so thats a game it's important for me to have this work in.
m
0
l
December 12, 2011 11:17:48 AM

The essential information in that post was that you need to set the default output in windows sound settings to "Speaker" - i.e. to analog 5.1 output.
I think you had it set to digital output (you deleted the first 4 images).
If it is set up that way you should be able to select the input for the DD Live in your Xonar software.
m
0
l
December 13, 2011 1:12:33 AM

It seems like that was the problem, I changed my output to speakers then found the input settings in the software. Thanks for everybodys help, especially JustAnotherNoob, much appriciated!
m
0
l
December 13, 2011 5:26:44 PM

^^ Yep, I ran into that problem a long time ago. If you do not select "speakers" as the default output device, you can't get any more then 2.0 out.
m
0
l
Anonymous
December 13, 2011 5:53:47 PM

yay :D 
m
0
l
!