Sign in with
Sign up | Sign in
Your question
Closed

USB Wireless Network adapters no longer working in Windows 7

Last response: in Components
Share
December 11, 2011 1:26:46 PM

Hi all, my first post here. Hoping desperately to get some guidance or troubleshooting next steps.

Wireless Cards Not Being Recognized by networking

I have two separate Wireless network adapters that I have tested against this Windows 7 home-built PC. Neither are working: after inserting the USB device, using device manager to add the correct (latest) Win 7 x64 drivers and installing the drivers successfully, Windows is still posting "problems" with the USB wireless devices. Troubleshooter is saying there may be a problem with the driver. I have reinstalled Windows, tried the devices in any of the 10 USB ports on my computer and have had no success. Proprietary connection software that comes with the devices fail to recognize the devices, though in Device Manager, they appear correctly, no exclamation mark or anything.


BACKGROUND:

I've had this P55-Sli based PC working for over a year, with one of the network adapters in question. Worked great, ran a little hot. I left it running for about a week for a really long download and when I came back to it, the graphics card was fried. Computer wouldn't post. Replaced the graphics card and bought a new wireless card since the other one was a little flaky (I often had to unplug it and plug it back in after a reboot so the computer would recognize it).

After installing the new graphics card with no problems, I attempted to install the new wireless adapter (a D-Link DWA125 Rev A2). Strange thing was that every time I have tried to install the driver for this device, the process completely stalls... until I unplug the device and then it finishes up. In other words the progress bar advances to a point and then just doesn't advance, even for an hour, until the instant I unplug the device and then it instantly finishes up. Note that this is not the case the with other adapter - the Netgear WGT111.
December 11, 2011 2:04:42 PM

Have you reported the issue to D-Link?
December 11, 2011 8:45:16 PM

If it were just the D-link adapter I would certainly not hesitate to point the finger at the manufacturer. In fact, I have contacted them and after running through the standard stuff (uninstall and reinstall the driver etc) the problem persists. The fact remains that the Netgear device which was working prior to the graphic card failure is also no longer working.
Related resources
December 11, 2011 10:23:44 PM

Does it fail on several PCs or only on a single one? If none work on a single PC, then that PC most likely is the source of the issue. Either replace the motherboard or the whole PC.
December 11, 2011 11:23:40 PM

"Either replace the motherboard or the whole PC". On what grounds would I do that? That's a pretty expensive replacement. What diagnostic basis could I establish first to ensure that this was the correct course of action? What hardware fault on the motherboard or PC could be responsible for such an issue?
December 11, 2011 11:49:39 PM

Do they work in other PCs? If so, then it probably is the motherboard's USB controller. Downloading normally doesn't fry a GPU unless something is wrong with the motherboard or the PSU. You ended up with 2 defective devices: a GPU and a wireless adaptor. You wrote"Proprietary connection software that comes with the devices fail to recognize the devices, though in Device Manager, they appear correctly, no exclamation mark or anything." Does the system detect and connect to a wireless router?
December 12, 2011 12:59:47 PM

I have just tested one of the wireless devices in another PC with similar architecture and OS and it works flawlessly. The issue is certainly with my PC. The system does not see the wireless router because it cannot find the wireless network adapter, which is odd, because as I mentioned, in Device Manager, the system DOES appear to see the adapter and doesn't post any issues. However, when I click on the big red "X" in-between my computer and "the internet" in the Network Manager, and the troubleshooter comes up and does its thing, it claims there may be a problem with the wireless card's driver.

Can one replace the motherboard's USB controller without scrapping the whole motherboard?
December 12, 2011 1:32:34 PM

You didn't mention it and I didn't ask, but do other USB devices like a keyboard or mouse work fine on your PC? Unfortunately you can't easily replace the USB controller. Before giving up, check the USB configuration in the BIOS.
December 12, 2011 1:40:41 PM

I have a wireless keyboard and mouse connected via a single Unifying USB dongle. They do appear to be working fine, though there was one - brief - moment where the network adapter actually functioned but then my mouse and keyboard stopped working!

What should I check in the BIOS?
December 12, 2011 2:01:54 PM

Check for a menu that says USB Configuration or Integrated Peripherals or whatever menu allows you to check/modify the USB configuration. That info can be found in the manual.

What bothers me is that the keyboard and mouse work (they probably are USB 1.0) while the wireless network adaptors don't, even after reinstalling the OS. Do you have a USB external hard disk or a USB key and if so, does it connect at USB 2.0 speed?
December 12, 2011 2:14:32 PM

Oh sorry, yes, I also connected a USB 2.0 HDD and backed up 100+Gb with no problems. Definitely at 2.0 speeds. Thank you for your continued interest in this question!
December 12, 2011 2:45:41 PM

The USB controller seems to be working properly, but not with the wireless controllers which is a bit strange. If you already performed a fresh Windows 7 reinstall, then something definitely is wrong or incompatible. At this point I'd probably consider a motherboard RMA if it still is under warranty. Just to be sure, the PC is close enough to the router to establish a good wireless connection?
December 12, 2011 2:52:11 PM

The PC hasn't moved since it worked before, so I suspect there is no issue with the range. After I exhaust all other possibilities I will take the board in - there should still be a warranty on it.
December 12, 2011 3:55:50 PM

It's possible that the bad video card caused some damage to the motherboard that affects some USB components, but not all.
December 20, 2011 12:11:14 PM

I"m trying to find some time to look into these issues. What diagnostics can I run on the motherboard to determine conclusively whether it's a USB fault?
December 20, 2011 4:20:06 PM

None that I know of. Have you tried a fresh OS install?
January 8, 2012 9:59:35 PM

GhislainG said:
None that I know of. Have you tried a fresh OS install?


Yes, actually, I did a complete reinstall of Windows 7. No joy. I've tried the cards in other CPUs and they work fine. I'm getting desperate. Any other ideas?
January 9, 2012 1:13:36 AM

I'd suspect a defective motherboard, but I can't understand why only a wireless device desn't work. If it's under warranty, then you should RMA it.
January 9, 2012 11:52:57 AM

I agree that the whole thing makes no sense. Could it be a power supply issue? Could the USB ports be getting SOME power but not enough to power a wireless antenna, but maybe enough to power a wireless mouse?
January 9, 2012 12:15:56 PM

Swapping the PSU is relatively easy, but I doubt that it will resolve the issue (though you won't know until you try it).
January 17, 2012 3:02:19 PM

Hello,

I seem to have the same problem and this appears to have started after the system auto updates on 11/01/2012. I had a D-Link DWA-140 wireless usb adaptor and this was working fine until that day and then stopped. I have then tried two different Netgear WNDA3200 wireless usb adaptor both appear to install and show as enabled but cannot connect, even the led does not come on at all.

On the D-Link it install and shows as disabled on network adaptors but when I try to enable it trys to but remains disabled.

Any help please.
January 18, 2012 3:19:57 AM

Same issue here both with IOGear and TP-Link USB wireless adapters. They install and show as enabled but cannot connect. Running Win7 64bit. The lastest drivers for each have been installed.
January 18, 2012 11:03:02 AM

I would contact each company's support because Microsoft either broke something or the drivers aren't fully compatible with the latest Windows 7 updates. If enabled, I'd disable the firewall to determine if it's causing the issue.
January 25, 2012 11:37:42 AM

Thanks to @ebear and @chaku for adding your experiences to this thread. So far I have been unable to discover the cause, and I have not yet replaced the motherboard as per @GhislainG's suggestion.

Do please note that my issue predates the 11/01/2012 update by nearly 6 months, so it may not be the same issue.
January 25, 2012 11:39:00 AM

@ebear and @chaku, please, even though it might be really tough to remember, if you do manage to resolve the issue, please return here and post your results - it will be really helpful for the others, or for anyone else who stumbles upon this thread.

Take the extra time and give back if you do get a result.

Best solution

July 27, 2012 3:16:44 PM
Share

Had similar problem. But my phone would connect to the WiFi. Both my Win7 machines would fail to connect for no reason.
Boot your computer with the USB WiFi removed from the computer. On a laptop or other build in WiFi, disable it and reboot.
When completely up and running, plug in and/or enable.
July 27, 2012 3:44:38 PM

Yeah, according to what I have been able to determine, there are possibly TWO things at play:

1. The BIOS on the EVGA board needed to be updated to the very latest update
2. There can be NO USB 1.0 devices plugged in. I don't know about maybe plugging them in AFTER the network connection was established like you suggest.

Under any circumstance, without swapping out the MoBo, this has gotten my networking up and running like a charm!
August 6, 2012 3:33:30 AM

Best answer selected by tomauger.
August 6, 2012 9:34:00 AM

This topic has been closed by Mousemonkey
!