Sign in with
Sign up | Sign in
Your question

Asus P8Z77-V will not power up

Last response: in Motherboards
Share
September 21, 2012 1:13:04 AM

I would appreciate if anyone can shed some light into this:

I built a new pc. keeping some compononents from my previous one

New parts:

Asus P8Z77-V
2x 4GB Corsair Vengeance 1866Mhz DDR3
Intel Core i5-3570K
Noctua D14
NZXT Phantom 410 case

Existing parts used:

Corsair HX 1000watt PSU
Sapphire ATI HD6870
2 x Western Digital Raptor
2 x ocz agility 3

Plugged in everything. Motherboard's led is turned on and green but when I try to hit the power button the fans spin for just a second and then stop and nothing happens. If I push the power button again nothing happens with the led still turned on.

Steps taken so far:

Checked every connection, ensured everything is in correct place, order.

Removed GPU, HDD, 1 ram, one at a time and at various combinations - No luck

Removed mobo from the case and plugged it to PSU to see if something is shorting it, again with GPU, 1 ram - No luck

I don't understand what is wrong. The mobo is getting power as can be seen from the led, also for a split sec the system seems to power up but only if I remove the PSU cable and put it back in.

Can anyone suggest anything?

More about : asus p8z77 power

a b V Motherboard
September 21, 2012 1:59:02 AM

You need a power good signal on the motherboard power connetor which is pin number 8 (gray) voltage should be between2.4v and 6.0v it takes around 0.1 to 0.5 seconds after you turn on the power switch.
September 21, 2012 1:04:15 PM

So you are saying this is probably a PSU fault? The only way to check this is to get a new PSU I suppose.
!