Sign in with
Sign up | Sign in
Your question

990FX Fatal1ty & FX-8150 1866mhz RAM No Post No Display No Beep

Last response: in Motherboards
Share
September 21, 2012 3:08:44 PM

Hi everyone,

I have decided to upgrade my Intel Quad Core (Q9300) based hardware to a more recent system. Basically I use my computer to study virtualization tech, play games and enjoy multimedia capabilities.

Recently I purchased following components:
Asrock Fatal1ty 990FX Pro Mobo Rev 1.03 (DEFAULT BIOS)
AMD FX-8150 CPU (Stock Fan)
Corsair Vengeance 1866 MHZ DDR3 RAM 4 GB x 4 = 16 GB Total (4 sticks of 4 GB)
600W Xilence XP PSU (Tested working from old system)
Cooler Master Stacker Tower Case
HD6850 GPU (Tested working from old system)

I have two questions:

1) Although i tested everything I can't get it boot successfully. No post, no display, no beep codes if speaker is attached and DR Debug LED displays only 00 as code and this code never changes.

My conclusion is that this mobo might need bios update to support FX-8150.

I tried reseating components and mounting mobo in mobo box instead of coolermaster case, I also ordered a second hand Sempron CPU to update bios, if this will save me.

2) Can i use Zerotherm Nirvana NV120 that i used to cool Q9300 CPU, at this mobo within FX-8150 cpu instead of stock cpu fan?

Any comments?
a c 108 V Motherboard
September 21, 2012 7:32:18 PM

Number 1 isn't a question, but I suspect that the mobo may be DOA; however, testing your theory couldn't hurt. A good idea would be to contact Asrock tech support and ask which of the updates, if any, add support for the FX-8150. You don't want to jeapordize your warranty by messing up on the BIOS flashing.

As for number 2, in my opinion (but I could be wrong), if you can mount the cooler, you should be able to use it. Other considerations are, though:

1. Proper heat dissipation
2. Real Estate (will the cooler impede installation of RAM?)
3. Does the fan connector match the header on the mobo (3-pin to 3-pin, for example)?
Related resources
Can't find your answer ? Ask !
September 21, 2012 8:06:28 PM

if you haven't already, check for bent pins. make sure cpu power is plugged in. also are fans turning on?
September 21, 2012 9:00:36 PM

Well, I checked for bent pins and no trouble. Fans working as expected. GPU has two fans and spinning at full speed. I think I should try my chances with SEMPRON 140 cpu if it arrives next morning, if not I'm going to call Asrock Customer Service and try to process a RMA.

Btw, my mobo arrived in original package with all accessories unpackaged. Except mobo didn't have a anti-static package which I used to see on most mobos I purchased so far.
September 21, 2012 9:14:12 PM

Exchange the MB and CPU for an i3+mb :p 
September 22, 2012 3:24:15 PM

Hi everyone, thanks for replies. Here are the news. Purchased a Sempron 145 and it posted fine. Then updated bios by flashing 1.80 (latest available at Asrock's website) and then tested each stick, gpu and other components. They all run fine. While doing those debug code led was displaying information correctly as i expected.

Then decided to mount FX-8150. Guess what. Debug code goes back to 00, no beep, no display and cpu fan is spinning.

I took at cpu and double checked that it does not have bent pins. My conclusion is that this cpu might be dead, or i need to do something I haven't tried yet.

I cleared cmos from jumpers and no luck.

The only thing left is touching Reset or Power buttons on mobo.

I read that on Asus forums those with debug code 00, could fix the problem by touching this Q-Reset button on their mobos.

http://rog.asus.com/forum/archive/index.php/t-3593.html...

Is it safe/unsafe to press those buttons while pc is powered on?

I'm going to send my cpu to service Tuesday.

Thanks.
!