Sign in with
Sign up | Sign in
Your question

SoundBlaster X-Fi XtremeGamer problem - It just refuses to play sound

Last response: in Components
Share
December 12, 2011 10:05:50 AM

Okay, I'm having some random hiccups with this new card I got...

I've been using my X58A-UD3R's onboard soundcard, but recently I realised that lockups I've been having in BF2 and 3 have been an issue of Realtek's drivers and Punkbuster. So, with EA unable to fix it, I decided to say "fudge it" and buy a new soundcard.

I ended up with the one on the title. Pretty robust, according to web reviews, and I got it for 40 euros retail, good price for it.

Thing is, sometimes it just refuses to play sound. I hook up the jack to its green slot and... nothing. The playback is identified and I can see the volume going up and down in the mixer, but the card refuses to get it through to the speakers.

So I thought maybe it's a problem of the speakers at first. I hook up the 5mm jack to my HTC Desire HD, and sound plays nice... So I think "what the hell, maybe I did something wrong.". Then I re-hook the jack to the sound card and voila, sound plays fine.
Sometimes this would happen on boot. Windows loads, I try to listen to something but no sound is played. I unhook and rehook the jack, and sound plays fine. Or I restart and again, voila, sound.

What might be causing that? Defective card?


Any other info you'd like me to provide?
December 12, 2011 11:26:20 AM

Or... Maybe a defective 5mm jack cable? Can these things even die?
December 12, 2011 11:31:59 AM

I would suggest un-installing the drivers for the onboard sound and the sooundblaster, then re-installing the soundblaster drivers.
Related resources
Can't find your answer ? Ask !
December 12, 2011 1:30:14 PM

clarkjd said:
I would suggest un-installing the drivers for the onboard sound and the sooundblaster, then re-installing the soundblaster drivers.


Already done so, good sire.
December 12, 2011 2:01:00 PM

You've disabled onboard audio?
And have chosen the X-Fi as default device in sound icon(speaker on desktop)?
December 12, 2011 2:08:06 PM

oh the joys of sound blaster! I will never do anything but onboard audio again lol.
There is a possibility that it is a bad cable, but when they die the problem tends to be more intermittant, and if you shake the cable you will hear it cut in and out. As they dont move much it is unlikely this is the problem.

Most likely it is the drivers, try loading some older drivers, or newer beta drivers if possible. Make sure that you have the right device selected in the audio hardware manager. Windows has a bad habit of switching to HDMI or other defaults before doing an installed card.

If none of that works try getting your money back and trying something else.
December 12, 2011 6:53:42 PM

Hi,

also check in the windows sound settings, whether the default output is set to 'digital' or 'speakers'. Should be speakers in your case, correct me if I'm wrong. Windows might set it to digital automatically if speakers are not detected on the respective socket. Actually I'd set the digital output in the XFi panel to disabled...
If remember it right that should be possible somewhere in audio HQ in control panel. If you installed it, that is...
!