Sign in with
Sign up | Sign in
Your question

CAN'T UPDATE DRIVER

Last response: in Graphics & Displays
Share
July 13, 2011 12:33:42 PM

I'm running XP Home on a Dell 5100C small form factor desktop. I have two

128 MB ATI RADEON X600 SE

graphics cards. I tried to update the driver but it doesn't update. The computer goes badda-bing badda-bong but when I look in Device Manager, the old driver is still there! :( 

I tried many times. First I tried to install OVER the old driver.
Then I tried uninstalling the old driver before installing the new one.
I did scans for registry problems, (with EUSING FREE REGISTRY CLEANER).
I also scanned with AVAST and SPYBOT.

I guess I was tired and depressed yesterday and I shouldn't've attempted something like this at that time! I downloaded and installed two programs, (reg cleaners), (WiseFixer and one other that seemed to be the same program with a different name), that I uninstalled a few minutes later because I didn't really trust them after they tried to charge me money after coming up with a bizillion problems that "needed to be fixed by their program". (I wouldn't've had a problem with them if they charged up front but when something acts a little sneaky like that, I guess I get nervous.

I stoopidly did that BEFORE I used EUSING FREE REG CLEANER.

I ended up having to restore the system because after trying to update that driver, the computer was now hardly working at all! Every command I gave it, took forever to complete! Just getting Properties from My Computer took, maybe, almost 2 minutes!!!

Now everything seems to be working again but I still have the old driver.

The main reason why I want this slightly newer driver for my Radeom video cards is I'm running X-Plane flight simulator... and it's not running quite right. I was told by the company that there was a graphics driver problem.

Anyway, so now I'm gonna be super cautious, (unlike yesterday). That's why I'm asking for help here. :) 

Any help will be very much appreciated. :) 

More about : update driver

July 13, 2011 4:18:01 PM

that's the latest driver on dell for xp (ATI 128MB Radeon X600 SE, v.8.162-050803a2-025672C , A04) dated 2005
m
0
l
July 13, 2011 9:09:07 PM

I know what driver is the latest. My problem is that I can't install it on my computer. I did my best to get rid of all the registry cleaning software that I had on the computer. And I SysRestored to a date that's most probably before I started using that stuff. While the computer actually seems to be running faster, I still can't get that driver! Now what happens is:

When I click on the ATI Uninstall Utility, immediately there's a message that says: Initiation Error. I tried to stop the process by pressing ESCAPE but when I looked, I couldn't find the ATI software on the RemoveSoftware list. I restarted the computer and it acted like the old driver was still there. It's not on the list after restart either.

I'm undoing the last restore in the hopes that the old driver at least will reappear.

Can anyone tell me how to fix the initiation error? I don't know if that'll fix the main problem of not being able to update the ATI driver but I don't know what else to do! :( 

What a horrible mess!

m
0
l
July 14, 2011 2:32:50 AM

try revo unistaller for the ati driver and use glary utilities .
m
0
l
!