Sign in with
Sign up | Sign in
Your question

Cannot detect usb mouse everytime the pc restarts

Last response: in Motherboards
Share
September 27, 2012 5:09:20 AM

Hi, i have a GA-970A-DS3 AM3+ mobo. I'm not sure though if this is the real problem or the mouse. Everytime i turn on or restart my PC, the usb mouse doesn't work. I need to pull it all the time then re-insert just to activate it. I just noticed this since yesterday. I tried looking at the bios for possible clues but can't see anything unusual. I don't have any spare mouse at the moment. Any idea what might be the problem and how can i fix it?




September 27, 2012 5:31:14 AM

maybe a bad mouse? is the mouse old and/or has the usb been damaged/wet/anything that could cause issues? and have u done anything to the PC since u noticed it? anything major(Updates,Upgrades,modification of bios,etc)
September 27, 2012 6:59:40 AM

mouse is less than a year old. No, i don't think there's any major changes/updates to the PC or windows since the problem occurred. PC is well placed in the room corner and hasn't been moved or opened for the past month.

But yeah, im also suspecting a bad mouse... i'll try to put it in my netbook when i get back from work later and see if it works.
Related resources
September 27, 2012 1:29:13 PM

looks like motherboard problem... i did not encounter similar problem in my netbook when i attached the mouse and have it rebooted.

or maybe, there's a settings in BIOS that could fix this... any idea guys?
a b V Motherboard
September 27, 2012 1:44:58 PM

Try enable legacy USB device/driver at bios option...
also something simmilar with enable usb support at startup/POST... (at bios)
September 28, 2012 12:15:52 AM

@rdc85, done that already but nothing happens.. all related to usb or mouse were already enabled.

it seems that there is something that the motherboard suddenly doesn't like about the mouse.. or its settings...maybe drivers.. Not really sure if there was recent update with the drivers. but my logitech controller can use any usb slot w/o encountering similar problem. I simply cannot use the mouse to any usb slot w/o re-attaching it after powering on. This is kinda weird.. ~_~
a c 431 V Motherboard
September 28, 2012 2:04:20 AM

see if the error happens on both usb 2.0 and usb 3.0 port. also check in your bios to see if there any usb handoff settings.
also check to see if the mb vendor has any usb bios updates.
September 28, 2012 4:35:58 AM

yes, same behavior with usb 2.0/3.0

can't find any "handoff" settings in bios. I just noticed when i use the mouse in my netbook, the mouse LED was already on during POST. unlike with my desktop, the LED stayed off when powering on or reboot.
a b V Motherboard
September 28, 2012 5:11:22 AM

It was a power saving and safety system. USB port won't supply power if the device not detected..

The problem as u guess the device not detected properly, usually it can be fix by enable legacy USB support on bios...

try to update the bios is good idea
January 10, 2013 5:37:05 PM

I am having the exact same issue except with my keyboard.... lights turn on during start up... then turn off once I get into Windows 7 (x64). I then have to go into the Devices and troubleshoot, get a "Standard USB Host Controller Error Code"....

Did you ever figure out how to resolve the issue?
!