Sign in with
Sign up | Sign in
Your question

CPU upgrade problem

Last response: in CPUs
Share
December 17, 2011 2:57:38 AM

Hey all,
I recently attempted to upgrade the CPU on my HP tower. I had a Phenom X4 9500 with the M2N68-LA motherboard and was attempting to upgrade to a Phenom II X4 960T with a 95 TDP. According to HP's website, this new CPU isn't on the compatibility list but then again the list was posted way before the Phenom II line was created anyway. Secondly, I've read several posts from users with my same equipment upgrade to the same new CPU successfully. Their bios didn't recognize the new CPU by name, but it functioned perfectly. My bios version is 5.13 I believe

Well, here is my issue. When I attempted to remove the old heat sink, the thermal paste wouldn't release and so I accidentally pulled the old CPU out of the socket without being able to release the lock. Everything visually checks out- no damage, no bent pins, etc and the new CPU seemed to sit down on the old socket just fine and it locked in. I hooked everthing up and went to power it up and the tower wouldn't run the bios. The fans all ran, the hard drives were spinning, the lights were on, but the monitor didn't get a signal from the video card (Nividia GTS 450). Long story short, I pulled the new CPU out thinking it was a compatibility issue and put the old one back in. Same issue, no bios boot. The original heat sink fan and CPU are back in, all cables plugged up, tried removing ram, video card, CMOS battery, ran through the CMOS clear with the jumpers, let it sit unplugged for over 2 hours, all to no avail.

Did I do something to cause my bios or Mobo to fail? Can I reflash the bios with a bootable USB drive?
Thanks

More about : cpu upgrade problem

a b à CPUs
December 17, 2011 3:18:34 AM

Get a magnifying glass and inspect the socket carefully for bent or broken pins. Sounds like damage to the socket.
a c 214 à CPUs
December 17, 2011 3:18:44 AM

It is very hard to see bent pins in the cpu socket , you usually have to use a magnifying galss to see the pins. All it takes is one. You can use a bootable usb drive but you said that the computer won't boot so you won't be able to get to the usb drive.
If you pulled the cpu out of the socket without releasing the lock then you most likely did damage something , you can't just pull the cpu out of a locked down socket without causing some damage to something. Maybe it wasn't the pins or the socket but it could be something that is near the socket. It does look like you tried everyhting.
Related resources
December 17, 2011 3:21:38 AM

Thanks guys. I looked into the socket with a magnifying glass but honestly I don't know what I'm looking for. I'll try to find a pic of a good socket and compare and report back.
thanks
December 17, 2011 3:32:06 AM

The cpu and socket relationship- is it a male/female thing where the socket is comprised of tiny holes?
a b à CPUs
December 17, 2011 4:06:10 AM

No. The socket has upright copper pins that make contact with flat points on the underside of the cpu. It is a contact by touch not insertion (lol). Eack socket pin should look to align in a perfect row and column of the array. A pin can be off by a slight angle and mis-function. Since neither the old or new cpu works in the socket it does seem some damage was done.
December 17, 2011 10:54:19 AM

Thanks Dogsnake and inzone, that makes sense and is more likely what my issue is, especially after the heat sink pulled it apart. I'm going to pull the mobo today and see if its anything I can fix, if not, time for a new mobo
December 18, 2011 12:57:45 AM

Well, the socket on the mobo is toast. Learned a lesson on that one, be more careful when pulling the heat sink. I ordered some new parts today-

This Mobo: MSI 880GM-E43 AM3 AMD 880G HDMI Micro ATX
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
This ram: G.SKILL Sniper Series 8GB
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
This CPU that I already had- AMD Phenom II X4 960T
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

this has got to be a good improvement over my stock Phenom X4 2.2ghz with 6gb DDR2 ram.
!