Removing "Set program access and defaults" from start menu

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Hi.

I am running XP, and somewhere along the way, the "Set program access and defaults" feature was installed (I haven't seen it on my other PCs, and I thought I was uploading all automatic updates for all of the machines).

Anyways, I did some research and decided I didn't need it. I made a backup of my registry and followed the instructions here: http://support.microsoft.com/default.aspx?scid=kb;EN-US;327931.

Specificially, I did the following:

Remove "Set Program Access and Defaults" Icon from the Start Menu
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Click Start, click Run, type regedit in the Open box, and then click OK.
Do one of the following:
To remove the Set Program Access and Defaults icon for the current user, expand the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

To remove the Set Program Access and Defaults icon for the all users who log on to the computer, expand the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

On the Edit menu, point to New, and then click DWORD Value.
In the New Value #1 box, type NoSMConfigurePrograms, and then press ENTER.
Right-click NoSMConfigurePrograms, and then click Modify.
In the Value data box, type 1.
Click Decimal, and then click OK.
Quit Registry Editor.
Restart the computer.

I rebooted the PC, but I still see the application in my start menu. I looked in the registry, and the item I created is in there.

Am I missing something? How do I get rid of this thing? Thanks.

I made the
2 answers Last reply
More about removing program access defaults start menu
  1. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    I just right clicked on it and chose "delete". Haven't seen it since.


    "No Spam Please" <nospam@microsoft.com> wrote in message
    news:E715D81A-B232-4FD5-AE31-EDB0285A9545@microsoft.com...
    > Hi.
    >
    > I am running XP, and somewhere along the way, the "Set program access and
    defaults" feature was installed (I haven't seen it on my other PCs, and I
    thought I was uploading all automatic updates for all of the machines).
    >
    > Anyways, I did some research and decided I didn't need it. I made a
    backup of my registry and followed the instructions here:
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;327931.
    >
    > Specificially, I did the following:
    >
    > Remove "Set Program Access and Defaults" Icon from the Start Menu
    > WARNING: If you use Registry Editor incorrectly, you may cause serious
    problems that may require you to reinstall your operating system. Microsoft
    cannot guarantee that you can solve problems that result from using Registry
    Editor incorrectly. Use Registry Editor at your own risk.
    >
    > Click Start, click Run, type regedit in the Open box, and then click OK.
    > Do one of the following:
    > To remove the Set Program Access and Defaults icon for the current user,
    expand the following registry subkey:
    >
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explore
    r
    >
    > To remove the Set Program Access and Defaults icon for the all users who
    log on to the computer, expand the following registry subkey:
    >
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explor
    er
    >
    > On the Edit menu, point to New, and then click DWORD Value.
    > In the New Value #1 box, type NoSMConfigurePrograms, and then press ENTER.
    > Right-click NoSMConfigurePrograms, and then click Modify.
    > In the Value data box, type 1.
    > Click Decimal, and then click OK.
    > Quit Registry Editor.
    > Restart the computer.
    >
    > I rebooted the PC, but I still see the application in my start menu. I
    looked in the registry, and the item I created is in there.
    >
    > Am I missing something? How do I get rid of this thing? Thanks.
    >
    > I made the
  2. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Hi,

    The simplest way to remove it:

    Right-click on the taskbar and select properties. Flip to the 'Start menu' tab and click on
    customize and flip to the advanced tab. Under start menu items, uncheck 'Set programs access and
    defaults'.

    --

    Anando
    Microsoft MVP- Windows Shell/User
    http://www.microsoft.com/mvp
    http://www.mvps.org

    Folder customizations
    http://newdelhi.sancharnet.in/minku

    Protect your PC!
    http://www.microsoft.com/protect


    "No Spam Please" <nospam@microsoft.com> wrote in message
    news:E715D81A-B232-4FD5-AE31-EDB0285A9545@microsoft.com...
    > Hi.
    >
    > I am running XP, and somewhere along the way, the "Set program access and defaults" feature was
    > installed (I haven't seen it on my other PCs, and I thought I was uploading all automatic updates
    > for all of the machines).
    >
    > Anyways, I did some research and decided I didn't need it. I made a backup of my registry and
    > followed the instructions here: http://support.microsoft.com/default.aspx?scid=kb;EN-US;327931.
    >
    > Specificially, I did the following:
    >
    > Remove "Set Program Access and Defaults" Icon from the Start Menu
    > WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require
    > you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems
    > that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
    >
    > Click Start, click Run, type regedit in the Open box, and then click OK.
    > Do one of the following:
    > To remove the Set Program Access and Defaults icon for the current user, expand the following
    > registry subkey:
    > HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    >
    > To remove the Set Program Access and Defaults icon for the all users who log on to the computer,
    > expand the following registry subkey:
    > HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    >
    > On the Edit menu, point to New, and then click DWORD Value.
    > In the New Value #1 box, type NoSMConfigurePrograms, and then press ENTER.
    > Right-click NoSMConfigurePrograms, and then click Modify.
    > In the Value data box, type 1.
    > Click Decimal, and then click OK.
    > Quit Registry Editor.
    > Restart the computer.
    >
    > I rebooted the PC, but I still see the application in my start menu. I looked in the registry,
    > and the item I created is in there.
    >
    > Am I missing something? How do I get rid of this thing? Thanks.
    >
    > I made the
Ask a new question

Read More

Configuration Registry Microsoft Windows XP