Sign in with
Sign up | Sign in
Your question

No display on AMD A8-3850 home build

Tags:
  • New Build
  • Systems
  • Displays
Last response: in Systems
Share
September 17, 2011 3:34:59 PM

Hi folks,

Just built a new PC and getting no display signal. Specs are:

Fractal Design R3 case
Asus F1A75-V Pro
AMD A8-3850 APU
OCZ ModXStream 500w
Corsair Vengeance 8GB kit (2X4GB) 1866MHz (as on QVL for motherboard)

Those are basically all the components I have set up.

Everything powers up OK, fans spin, etc. Various lights come on on the motherboard (including the MemOK LED).

I've tried DVI and D-sub cables (both work with my current PC/laptop), a known working PSU, CMOS reset (using jumpers, with and without battery). I've also tried only PSU, motherboard, APU.

I currently have no internal speaker so can't check for POST (expecting one due Monday, although I may have an RMA ticket by then).

Given that I'm having issues with memory and graphics, I suspect the APU (both are built into it, right?).

Anyone got any ideas?

Cheers,

Edit: should mention I also tried a PCI (not PCI-e) graphics card borrowed from a friend, still nothing. This is also my 3rd PC build, first time I've had an issue I couldn't fix.

More about : display amd 3850 home build

September 17, 2011 3:56:47 PM

Thanks.

I've actually looked through that list a couple of times and checked as much as possible (I don't have a speaker at the moment so can't check that step.

I suspect the CPU is the most likely problem so I'll try to RMA that before anything else.

Cheers!
Related resources
September 17, 2011 5:49:51 PM

I doubt it is the cpu. I would try to boot woth only one stick of RAM and then try the other. Make sure that you plugged all the power connector. The large one (20+4 pins or only one 24 pins) AND the small one appart of the main one. Unplug all hdd or dvd and try it out of the case on a non conductive surface.
September 18, 2011 12:26:41 AM

Thanks, guys.

This is now solved.

I suspected the APU as I was getting a lit LED indicating a memory fault as well as the graphics issue. I tried both/single/no sticks in various configurations but still had errors.

It is now working fine after I removed and re-inserted the APU. However, I had to remove an re-attach the HSF in order to re-insert the APU so will likely need to invest in a good cooling solution as it's now likely less effective than it should be (getting as much as 62c at idle, fan at 5000rpm, which is insane).

Making do with underclocking and undervolting (which Llano APUs can apparently cope with quite well) for now.

Cheers!
September 18, 2011 12:43:19 AM

Glad re-seating the CPU fixed the issue. I'd check the heatsink as that 62C at idle does not seem normal. Try using "Core Temp" if you are using something else.
!