Sign in with
Sign up | Sign in
Your question

Monitor losing signal?

Last response: in Graphics & Displays
Share
July 17, 2011 10:22:09 PM

Recently, after about 3-5 minutes of loading up and playing a game on my PC, my monitor will go completely black with "No Signal" on-screen. The sound will cut off, too but my PC is still on. My VGA cables are fit in snugly and not loose, I have tried rebooting and updating all my drivers and even re-installing them. I have scanned my computer with both Avast! and Spybot and cleared everything out, as well as defragged it, and so far nothing has solved the problem.

I'm at a loss and I have no idea what to do except pull my hair out. I'm thinking about rebooting and re-installing my OS (Windows 7 64-bit), but I'm not even sure that will solve my problem. I have looked at questions all over the web similar to mine but so far no answers I've come across have helped. I can do just about anything else on my computer, but if I as so much play a game, it will always do this.

Any ideas/suggestions would be GREATLY appreciated. I'd love to get back to playing on STEAM, as I just bought a big collection of games that I haven't played yet.

Here are my specs:
Dell Inspiron 546
ACPI x64-based PC
AMD PCI Express (3GIO) Filter Driver
AMD Phenom(tm) || X4 945 Processor
NVIDIA GeForce GT 220 Graphics card

More about : monitor losing signal

a b U Graphics card
July 18, 2011 12:07:53 AM

So it seems things go black when your PC encounters more than a minimal graphics load. Unfortunately, there are a few hardware issues that might cause this problem.

Assuking you habven't made any recent hardware or major software changes, I'd first try my graphics card in another PC. If it games ok, I'd then try a different psu in my own PC. I think one of those two is most likely the source of your problem.
m
0
l
!