Sign in with
Sign up | Sign in
Your question

Sabertooth 990FX Rev. 2 - Updating Bios

Last response: in Motherboards
Share
October 3, 2012 3:40:56 AM

So, I've just installed my new motherboard, all has gone well, except, now I am trying updat to the new 0906 Bios (mine is currently 0304). I've gone to ASUS's website, selected the Rev. 2 Sabertooth, downloaded the latest 0906, unzipped, renamed from .CAP to .ROM, stuck it on my freshly reformatted FAT32 2GB drive key, and in the EZ Flash utility I am getting "selected file is not a valid EFI bios."

Other things I have tried:

Re-formatting the drive key to just FAT
Re-formatted back to FAT32 and renaming the ROM file to something under 8 characters
Re-formatting another 16GB drive key I had laying around, to FAT32
Downloading an older Bios update, e.g. the next step up from my version (0601)
Tried taking the above older Bios update and trying on the two different drive keys I have
Renamed that file to something shorter...

Nothing I do works, I can even try navigating through my HDD, from EZ utility and same error. I have the Revision 2 mainboard, not sure why this isn't working.
October 9, 2012 5:25:24 PM

Hi have had the same motherboards, my advice to you I'd do not update the bios if your current bios is good, you should only update the bios if there is any instability in system.
November 2, 2012 4:39:45 PM

u dont have to rename it.same mb used fat32 unzipped rom to flash drive and that was it,good luck
!