Sign in with
Sign up | Sign in
Your question
Closed

6970s + GTA IV = bad performance?

Last response: in Graphics & Displays
Share
July 20, 2011 1:51:27 AM

GTA IV won't let me raise any of my graphical settings. Resolution is stuck at 800x600. I know all about GTA's bad coding and heavy CPU usage...but really? This is just beyond frustrating. Here are my system specs:

AMD Phenom II x6 1100t (cooled by Zulman aftermarket cooler)
2 Sapphire 6970s (crossfire)
Asus Cross-hair IV
8GB of RAM *G.SKILL Ripjaws Series DDR3 SDRAM DDR3 1600*
Ultra 1050 Watt Power Supply
Samsung 1TB harddrive
HAF 932 case

My resolution is 1680x1050.

What's the deal?!!!

I've got the latest drivers (11.6). And these two cards have been installed since the building of my computer. No left over drivers.

These are other benchmarks with FRAPS:

Just Cause 2: (max settings, no vsync or AA)....... 48 fps min/80 fps max
Borderlands: (max settings, no vsync or AA).........35 fps min/55 fps max
BFBC2: (max settings, vsync, x4 AA)..........solid 60 fps
Terraria: 58 FPS
3Dmark11 score: can't remember exactly...but scored somewhere between 8000/9000

Help. Please. Before I burst into tears.





July 20, 2011 2:53:02 AM

have you installed the latest gtaIV patch? You should also look through gtaiv tweak guides. There are settings that allow you to force any setting you wish regardless of card.
Score
0
July 27, 2011 5:46:10 AM

You can always try removing the limiter on the graphics settings, by entering in a command on the games shortcut, you would have to look it up on google cause i dont remember. I do know this fixed an issue with one of my other PC's with a 5870 in it.
Score
0
Related resources
July 27, 2011 5:59:46 AM

I found this on another thread:
Quote:
I had similar problems, I solved them by creating a file in my GTA:IV installation folder named "commandline.txt" and typed the following to allow me to change the settings.
"-nomemrestrict -norestrictions"
This will allow you to change the settings as you like.

The 8600M GT GDDR3 in the Asus G1S has 256mb of memory; which is lower than the memory that GTA:IV thinks the video card must have for basic settings, so GTA:IV restricts one from making the settings more demanding.

http://forum.notebookreview.com/asus/333841-g1s-gta-iv....
Score
0
July 31, 2011 5:24:35 PM

I have the exact same problem.

My rig:
i7-2600k
2x 6950 with 1x Hawk 460GTX (For Physx)
Asus Evo MB

I made that commandline.txt and typed the required inputs but still can't make any changes. At the bottom of the game it is seen as 275/4000 as GPU usage (and it is green) still can't change anything

Update:

Ok now i have managed the commandline.txt and can adjust Video settings however, it is red at 1500/4000 and after 20-25 secs run i get Fatal Error: RESC10.

Btw my CPU is @4,5Ghz and have 8GB 1600Mhz Ripjaws X Rams
Score
0
July 31, 2011 6:20:29 PM

You might want to attempt to back off the overclocking and see if it works better. GTA is very CPU intensive, it may be pushing your CPU harder than it can handle.
Score
0
July 31, 2011 6:26:13 PM

@slyly, you might also want to start your own thread instead of hijacking this one.
Score
0
July 31, 2011 6:37:48 PM

@mousemonkey i wasn't hijacking anything i was simply trying to keep everything organized (in case commandline.txt doesn't work for other people too) which is called as critical thinking. However it was my stupidity to think such an arrogant person who deletes replies without any warning and accusing people with hijacking could think.
Score
0
July 31, 2011 6:42:10 PM

you could have just kindly pointed out that you were only adding information to the thread and that you had not asked a question.....if it adds to the possibility of answer discovery, i fail to see the harm
Score
0
July 31, 2011 6:42:23 PM

slyly said:
@mousemonkey i wasn't hijacking anything i was simply trying to keep everything organized (in case commandline.txt doesn't work for other people too) which is called as critical thinking. However it was my stupidity to think such an arrogant person who deletes replies without any warning and accusing people with hijacking could think.

You should start your own thread and link to this one in that case rather than being arrogant enough to feel that simple etiquette and forum rules do not apply to you because you are 'special' somehow. And resorting to insults when things don't go your way is a fast track to a ban, so roll your neck in.
Score
0
July 31, 2011 6:44:55 PM

@mousemonkey you should have wrote that before deleting my post and saying me to open a new post. Not everyone checks forums all the time. I never thought i was "special".
Score
0
July 31, 2011 6:50:24 PM

slyly said:
@mousemonkey you should have wrote that before deleting my post and saying me to open a new post. Not everyone checks forums all the time. I never thought i was "special".

I did, it's right after bystander's response to your first post.
Score
0
July 31, 2011 6:53:49 PM

Mousemonkey said:
I did, it's right after bystander's response to your first post.


@slyly, you might also want to start your own thread instead of hijacking this one.

This doesn't look anything like "You should start your own thread and link to this one in that case". Anyways ban me if you like or the discussion will take forever. So rather if you ban or not i will stop responding to the topic and make a new one (plus if you just let me write here it would take not longer than this)
Score
0
July 31, 2011 6:56:53 PM

Just start your own thread and be done.
Score
0
July 31, 2011 7:26:02 PM

@slysly quit your cryin'

@everyone else

What about the Ultra psu aren't those know to be kind of crappy? Correct me if im wrong but if the 6970s are being under-supplied then there is your problem although it sounds more of a gta iv issue in the end, just trying to state what might not have already been stated.
Score
0
July 31, 2011 7:30:56 PM

^great but we are not here trying to solve your problem

@OP is your cpu at stock? if so oc that puppy its a little weak at stock per core, and in gtaiv your going to need 4 strong cores to begin with, even before considering the gtaiv tweaks you might need to do.
Score
0
September 18, 2012 2:00:40 PM

the problem is crossfire do to bad coding for crossfire go in to your ati catalyst control center (ccc) and turn off your crossfire and you game will work and you can max out the settings leave shadows off and night shadows off to get about 30 to 60 fps the reason i know is i'm running the same set up as you



Monster

AM3 ASUS CROSSHAIR IV FORMULA AMD890FX ROG
AMD PHENOM II X6 1100T 3.30G/2000/9M/AM3 BLK
CORSAIR VENGEANCE 1600MHZ DDR3 8GB KIT C9
CORSAIR VENGEANCE 1600MHZ DDR3 8GB KIT C9
SATA3 600.0 W.D 10K 32M V-RAPTOR WD6000HLHX
SATA2 1.5TB SEAGATE 7200.11 32M ST31500341AS
BD-R BLU-RAY ASUS BW-12B1LT SATA 12X OEM BLK
KB LOGITECH G15 GAMING KEYBOARD USB
MOUSE LOGITECH OPT B100 USB BLK OEM
SAPPHIRE PCIE RAD HD6970 2048M HDMI LITE
SAPPHIRE PCIE RAD HD6970 2048M HDMI LITE
HAUPPAUGE 1213 WINTV-HVR-2250 MCE PCIE1X 2TUN
1200W ATX ANTEC HIGH CURRENT PRO HCP-1200
CASE EATX CM HAF X 942 NOPS
Samsung SyncMaster T240
Logitech Z-5500 Digital 5.1 Speaker System
CPU FAN CORSAIR HYDRO H70 H2O CWCH70
Score
0
September 18, 2012 5:31:00 PM

This topic has been closed by Mousemonkey
Score
0
!