Sign in with
Sign up | Sign in
Your question

PCI simple communications controller problem with z68m/usb3

Tags:
  • ASRock
  • Communications
  • Controller
  • PCI
  • Motherboards
Last response: in Motherboards
Share
October 4, 2012 2:14:44 AM

Hello,
Help! I can't find the driver for PCI simple communications controller.

I have a sapphire radeon 6770 card on the pci slot and it won't show on device manager even after installing, uninstalling, reinstalling the driver a number of times now. I've tried downloading from sapphire and amd but nothing works.

Have also tried reinstalling drivers for my z68m/usb3 mobo but still nothing (although it did solve my SM bus controller problem).

Funny thing is, system was working perfectly first time I installed everything. But after an update for WOT, was advised to uninstall and reinstall latest graphics card driver...and that's when my problems began.

Am running Win 7 64 if it matters and it's updated.

Am at wits end. And yes, I have searched this and countless other forums but to no avail. Appreciate any help on this.

More about : pci simple communications controller problem z68m usb3

a c 156 V Motherboard
October 4, 2012 3:45:20 AM

what is the full name of that wot you install that ask you to remove and reinstall graphic driver
m
0
l
October 4, 2012 8:39:05 AM

World of Tanks
m
0
l
October 4, 2012 11:08:52 AM

Found solution:
IntelĀ® ME 7: Management Engine Driver for Intel 6 Series Chipset-Based Desktop Boards
http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...(Intel+ME+Management+Engine+Driver+for+Intel

Just check what chipset your mobo has and then look for appropriate Management Engine Drive on Intel.

Thanks.
m
0
l
!