Fans on but motherboard doesn't beep at start

I've bought a new motherboard, processor and ram:
MB: Asrock Z77 Pro3
CPU: Intel i5 3450
RAM: 8 GB Corsair 1600MB CL9 DDR3 (Vengeance Module Kit)

A bit too optimistic at first I plugged everything in and started the computer. All the fans turned on (including graphics card), but there was no beep from the motherboard. Now I've reduced the configuration to motherboard and one stick of RAM (and the powerbutton and speaker) and still all the fans turn on but no beep! I've also tried to remove the CMOS battery for more than 10 seconds.
My power supply is quite new as well, it is a one year old Sharkoon 600W.
I guess one of the components I'm using, i.e. Motherboard, CPU, RAM, or power supply must be broken, but how do I determine which?

PS: The motherboard does beep 3 times when I remove the 1 RAM stick.
7 answers Last reply
More about fans motherboard doesn beep start
  1. it could be the bios is to old to post. the mb needs bios 1.2 to post see if there a bios lable on the mb on in the mb box. check that you have the video connected to the mb and pull the gpu if your using on sometime the onboard video will be the first video device. check that you connected the 4/8 pin atx power. some people forget to connect sll the power plugs to there video card.
    try seeing if the mb will post sitting on the desk. (break board). sometime there a short or missing brass standoff.
  2. Hey thanks for the tips: I dont know the version of my bios and I can't find it on the mb... how can I find out?
    What do you mean with "video connected to the mb"? As I said I just have the motherboard, cpu and one RAM stick connected. Shouldn't that be enough to check if those components work (i.e. one beep when I turn it on)
    I also tried with my Radeon HD 5850 in one PCI Express slot and I connected the power plugs to it. Again the same. (no beep)
    I will try to start the mb sitting on my desk when I get home tonight!
  3. OK so now I've tried every configuration possible also outside the chassis (mb on a cardboard box...). I've run out of ideas. Does anybody know how to determine which part is broken?

    PS: smorizio mentioned that it might be that my motherboard's bios version is too old for the RAM, but unfortunately I don't know how to find out which bios version I have.
  4. may need to email mb vendor tech supprt they could tell you by the ser# of the mb what bios is on it.
  5. OK I contacted Asrock and they said that they've tested similar RAM that work with the motherboard, but not my particular ones (theyll do it soon though). Nevertheless I sent the RAM back and ordered RAM that were on the list of compatible memory.

    The sticker on my motherboard for the BIOS says:
    Z77 PRO3
    P1.30-15A
  6. OK another update: I sent the RAM back and bought new ones. Still the same problem. I tried a different power supply. Still the same problem.

    I guess I'll have to send back the motherboard and processor.
  7. the lable you posted says 1.3 that may be saying bios 1.3 or mb rev 1.3 my gut would be bios rev.
Ask a new question

Read More

Motherboards RAM