Sign in with
Sign up | Sign in
Your question

Failed Bios Update on ASUS Sabertooth X58

Last response: in Motherboards
Share
October 9, 2012 8:07:27 AM

Hey everyone, so in the middle of what I thought was a routine bios update via a usb stick and ez flash 2, the update process hung on the erasing boot block step. Initially, I thought it was just taking extra long, so I left it there for about half an hour and came back to the exact same screen. Figuring that the update process failed, I rebooted the system and was greeted with the message:

Boot Block Compatible Version Ver.027
Please do NOT insert any disc into CD-ROM or Floopy drive if you want to recovery with an USB device.
Bad BIOS checksum. Starting BIOS Recovery...
Start Erasing Boot Block.../

Now I recognize that this is the start of the bios recovery util where it will start looking at cd drives and floppy drives for a rom file to recover from, but as it stands now, it is still stuck at trying to erase the boot block and won't proceed any further. I've tried clearing CMOS, but it just takes me back to the exact same screen as above. If anyone has any ideas on how I can get around this to recovering the BIOS, please let me know.

Thanks!
a b Ĉ ASUS
a c 85 V Motherboard
October 9, 2012 8:32:41 AM

Copy the DOS based flash utilities on a formatted USB stick and also copy the unzipped Bios ROM file onto it.
Follow the Instructions to flash the BIOS using the USB stick from the Asus website and see if it manages to complete the process.
Make sure that the USB stick is not infected with any other things before you go ahead with the process.
m
0
l
October 9, 2012 2:30:29 PM

Thanks for the suggestion. I created a DOS bootable USB stick and copied over the afudos util and the bios rom file, but the problem is still there. I can't seem to bypass that initial screen where its trying to erase the boot block in order to choose to boot from the usb stick. Is there something I can do to make it force boot from the usb stick?
m
0
l
a b Ĉ ASUS
a c 85 V Motherboard
October 10, 2012 7:54:40 AM

Have you tried using the crash free utility?
m
0
l
!