Sign in with
Sign up | Sign in
Your question

New system won't boot. B2 error on LED

Last response: in Motherboards
Share
October 10, 2012 7:35:07 AM

I bought my ssystem last week. All hardware came in and I build it up.

This is the hardware I have:

Mainboard: MSI X79A-GD65 (8D)
CPU: Intel Core i7-3930K/3.2GHz 12MB LGA2011 Hexa-core
Case: Corsair CASE Graphite 600T
Power supply: Thermaltake SMART 650W/ 80plus
Cooler: Thermaltake Contac 39
SSD: Intel SSD 520 series 240GB
HDD: Seagate HI 3.5" 2TB Barracuda 7200RPM
Graphics: MSI N660Ti PE 2GD5/OC GTX660Ti
Memory: CORSAIR DDR3 1600MHz 16GB Kit 2x8GB Domi DDR3 - 240 pin - 1,5V - CL9 - 2x 8 GB Kit
DVD: DVD RW AD-5280 24x DL SATA Black Bulk 24x/24x - Serial ATA

The problem:
Everything looks fine all fans are spinning when I power on the computer. Keyboard lights up. I can even press del to enter setup.
I never get into setup though. It just displays error code B2 in the bottom right corner and a blinking cursor in the top left corner.
So always error B2. I see this error to on the LED's in the mainboard.

What I have tried:
- Boot the system with one memory module in Dimm socket 1
- Boot the system with on memory module in Dimm socket 3
- Place the graphic cards in another PCI-E socket
- Double checked the connector of the power on the graphic card, the mainboard, near the cpu and the graphic card power on the mainboard.
- Boot the system without any devices, just cpu, memory and graphic card.
- Reset the CMOS with the button on the back of the mainboard.

Can somebody help me solve my problem? I have no idea what to do anymore?

Oh: 1 thing just came to mind, I have connected all my system fans to my case instead of on my mainboard. I can manage the speed that way, can it have something to do that there is no Sysfan1 connected to the mainboard? (A bit far searched I guess).

More about : system boot error led

a b V Motherboard
October 10, 2012 8:05:20 AM

1. Make sure that CPU fan is connected to CPUFAN1 header near the 8 pin power connector.

2. Insert memory stick into DIMM1 first.

3. According to the manual the B2 state is 'Console Output/Input devices/Console initialization and Load Option ROM (VGA, RAID, parallel ports, serial ports……)'. Not very helpful.

4. On your motherboard there is a switch to use a backup BIOS. It's called Multi BIOS Switch and it is located between 24 pin power connector and DIMM3 slot. Switch it and see if it helps. Never switch it when pc is turned on!

5. Make sure that OC Genie button is not pressed.
October 10, 2012 8:13:42 AM

Thanks for your reply.

I have tried to use the multi bios function without result.
The fan is connected to CPU FAN 1.

I got some insight on the MSI site as well.
It could be possible that the cpu I have is a C2 Stepping model and that the Bios is not supported for this CPU.
This would be bad because I do not have another LGA 2011 cpu to flash the bios with.

I will keep this topic updated.

Any more idea's are more then welcome.
Related resources
October 11, 2012 1:44:03 PM

I have just tried firing up my first build tonight and it's coming up with the same error. I have a gigabyte z77x-up5 th motherboard. I try some of these solutions and see how I go.
October 11, 2012 2:05:05 PM

I found the problem. After some testing the part that caused the problem was the Videocard. I had a MSI Geforce GTX 660 TI. I put my old ATI 4870 back in and it booted straight up. I hope this tip helps you.

It is definately worth testing.
October 12, 2012 2:58:09 PM

Plucked the gigabyte gtx 660 I had put in during assembly and it booted straight away thanks! So does this mean this graphics card is kaput or it needs some drivers installed or something?
December 8, 2013 9:51:47 AM

Recently purchased an ASUS GTX 770 and had this exact same issue, had to boot the Video Card in my buddies system and then upgrade the Graphics Card's BIOS (Fairly simple, downloaded an .exe from ASUS), put it back in my system and Bam! Booted first try. I know its a couple months late but hopefully it helps someone xD
!