Sign in with
Sign up | Sign in
Your question

Can't update BIOS using multiple methods

Last response: in Motherboards
Share
October 11, 2012 4:16:08 PM

Just bought a used motherboard, a Asus P5n-t with a E8400 dual core 3ghz, 4gb ram and a 8800gt.

I bought a new PSU, 530 watts, swapped over my hard drives from my old computer and tried to boot. Everything was dandy until it tried to start Windows at which point I got a blue screen. No big I thought, I'll just do a fresh install of Windows. I waited a few days to do the install, but when I put the hard drives back in my new computer my video card didn't work. All I was getting was black static. I swapped in another PCI-e card and the video was fine, however my SATA drives weren't detected!

I checked the bios and they're the oldest revision, 1001. I thought updating the BIOs might fix my problem, so that's what I've been trying to tackle for the past day. First I tried putting the 1702.bin (lastest BIOs) on a USB stick and using the EZ-Flash utility. When I did that I was presented with two drive letters, both which were shown as empty.

Next, I tried a bootable USB stick using this method:
http://www.biosflash.com/e/bios-boot-usb-stick.htm
I entered boot option set-up and it correctly determined that there was a SanDisk usb drive attached and I set it as the primary boot option. When I tried to boot however, I got a 'please insert system disk' error.

I tried a bootable CD-ROM using the same directions, but still got the same error.

I then tried to see if I could boot anything, so I used a Windows 7 CD and a live linux distro, backtrack. Both worked!

I'd love any suggestions on getting my SATA drives back and working, as far as I can tell nothing had changed from when it worked to when it didn't.
October 11, 2012 4:29:18 PM

I just updated the BIOs, however, it didn't solve either of my problems. SATA drives still aren't detected, and the 8800gt doesn't work. On the upside, the appearance of the static from the video card changed, now it's multicolored!
m
0
l
a b Ĉ ASUS
a c 180 V Motherboard
October 11, 2012 7:59:48 PM

If your sata drives were loaded with the sata mode in the bios set to AHCI then you have to set the sata mode to AHCI , if the sata mode was set to IDE when the drives were working in the other computer then you have to set the sata mode to IDE.
m
0
l
Related resources
October 11, 2012 8:36:15 PM

The board I'm using has the 780i chipset which doesn't support AHCI. The old computer predated the AHCI standard. So I don't think that is the problem.
m
0
l
October 11, 2012 9:01:42 PM

Just got it to recognize a brand new SSD on sata 3. I'm currently installing Windows, will update after install and see if I can get my other two drives recognized.
m
0
l
October 11, 2012 9:33:41 PM

Back again, Windows 7 installer couldn't recognize the drive, even using diskpart. I rebooted and now the drive is not detected. I'm thinking it may be time to throw in the towel...
m
0
l
a b Ĉ ASUS
a c 180 V Motherboard
October 11, 2012 10:38:52 PM

When using windows installer did you have the option to load drivers for the hard drive?
m
0
l
October 11, 2012 11:00:37 PM

yes, there was options to load external drivers. However, SATA II drivers should be native to win7
m
0
l
a b Ĉ ASUS
a c 180 V Motherboard
October 11, 2012 11:04:11 PM

Sometimes hard drives can have drivers, it's rare and there is one instance when I had to load a driver for Windows to see the drive.
m
0
l
October 12, 2012 2:01:31 AM

The problem is that the motherboard does not recognize the drives...

I'm thinking now that I could use a PCI-e SATA controller, I just need to find one that I can boot from.
m
0
l
a b Ĉ ASUS
a c 180 V Motherboard
October 12, 2012 2:55:09 AM

I went back over all your responses and your original post and there was something that I didn't see mentioned and am wondering if in fact you tried it and that is to try the different sara ports, there are I believe 6 of them. Also I would ask which sata ports that you do have thedrives connected to. Granted this is an old board since it's socket LGA775 but on the sata ports now they have the Intel chipset controlling some of them and the Marvell or Asmedia chip controlling the others. I think that if you have the OS drive connected to the Marvell chip it won't boot and if you connect it to a sata port that is connected to the Intel chipset that it will boot. This is just another shot in the dark here as were're running out of options.
m
0
l
October 12, 2012 4:45:03 PM

Yeah, I tried every sata port, sata port 3 worked once, but only that one time. There are 6 onboard sata ports and one external marvell esata port. I tried disabling the marvell just to see if it was interfering, but nothing changed. I just bought a sata III controller card, im going to see if i can use that to boot from.
m
0
l
a b Ĉ ASUS
a c 180 V Motherboard
October 12, 2012 4:49:31 PM

The pci-e sata controllers are either Marvell or Asmedia and drivers need to be loaded to use them for a boot drive to be connected.
m
0
l
!