Sign in with
Sign up | Sign in
Your question
Solved

Is Physx automatically disabled in games when using an ATI/AMD card?

Tags:
  • Graphics Cards
  • Games
  • Physx
  • ATI
  • Graphics
Last response: in Graphics & Displays
Share
July 26, 2011 9:08:31 AM

I am asking this because,

I am playing X-Men Origins Wolverine and I get lag. It has the Physx logo in the beginning, so I am guessing it uses it.

I also just finished playing Batman: Arkham Asylum, a new game than Wolverine Origins. Both use similar graphic engines I believe. However, with Arkham I get 60 FPS, very smooth game play. With Wolverine, I max 50 FPS, and I get lag. I thought because maybe, even though I have an ATI/AMD card that it Wolverine still keeps Physx on. Batman offers to turn it on in the main menu. Wolverine does not.

Is there such a way to make sure it is turned off in the Wolverine config.ini file?

Do you think that could be a problem, or is my note book just having some trouble playing Wolverine.

EDIT: ASUS N61JQ notebook, i7 turbo boost 2.8 CPU, ATI 1GB 5730

EDIT: Also noticed that in the Wolverine game, the game is more dynamic compared to my other games. The Wolverine game has trees moving, ground effects and things moving when walking.

More about : physx automatically disabled games ati amd card

a c 214 U Graphics card
July 26, 2011 10:49:20 AM

PhysX is a part of how the game works and therefor it needs to be running in order for the game to work.PhysX doesn't have any performance impact if your using an ATI card.

The reason you are getting lag is because the 5730 isn't a very powerful card.It's the i7 that actually makes you get such high fps.
m
0
l
a b U Graphics card
July 26, 2011 2:26:02 PM

"PhysX doesn't have any performance impact if your using an ATI card"
That's simply because using an ATi card means that PhysX is not in use, at all.

It is not required for the game to work, if it was the game would not play at all since ATi cards currently do not support PhysX in any way shape or form.

The 'lag' that you speak of is most likely that you have Vsync turned on.
With 50fps you should not notice any jittering or input lag.
Check the game options for vsync and disable it.
A Radeon5730, even a mobile one should handle that game just fine.
m
0
l
Related resources
a c 214 U Graphics card
July 26, 2011 2:35:29 PM

I believe that PhysX is also a part of the game engine.I've tryed uninstalling it before because I was using a ATI card but the game wouldn't work after that.
m
0
l
a c 124 U Graphics card
July 26, 2011 3:08:27 PM

Actually PhysX can be enabled with an ATI card.

So basically there's 2 parts to PhysX. On one hand, it's mainly just a general physics engine like Havoc or Bullet or a myriad of others used in basically every single modern game. However, PhysX is special because it has the ability to also use GPU accleration for more advanced physics modelling of destruction, cloth, particles, etc.

For the most part, the acceleration is automatically disabled with an ATI card, and even with an Nvidia card it seems to be either off or on Low. However, PhysX is sometimes capable of running off the CPU and therefore can be enabled even without an Nvidia card, but it is meant for paralized processing so it usually causes nearly unplayable framerates when run off CPU.

Basically, chances are you need to reduce the settings in Xmen and/or increase them in Batman (FYI, as far as I know Batman will only do AA if you enable it in CCC). It's worth double checking in any PhysX acceleration is enabled but I doubt it will be (plus I'm pretty sure XMen is not GPU Acceleration enabled).
m
0
l
July 26, 2011 9:14:17 PM

wolfram23 said:
Actually PhysX can be enabled with an ATI card.

So basically there's 2 parts to PhysX. On one hand, it's mainly just a general physics engine like Havoc or Bullet or a myriad of others used in basically every single modern game. However, PhysX is special because it has the ability to also use GPU accleration for more advanced physics modelling of destruction, cloth, particles, etc.

For the most part, the acceleration is automatically disabled with an ATI card, and even with an Nvidia card it seems to be either off or on Low. However, PhysX is sometimes capable of running off the CPU and therefore can be enabled even without an Nvidia card, but it is meant for paralized processing so it usually causes nearly unplayable framerates when run off CPU.

Basically, chances are you need to reduce the settings in Xmen and/or increase them in Batman (FYI, as far as I know Batman will only do AA if you enable it in CCC). It's worth double checking in any PhysX acceleration is enabled but I doubt it will be (plus I'm pretty sure XMen is not GPU Acceleration enabled).


Well with Batman, it offers me the option to disable or enable. I leave it disabled, as the performance boost is well worth it. Wolverine does not, thought that might be a problem.

If that is not the problem, I am guessing my notebook is just having more trouble running Wolverine because the view distances are longer.

PS: For Batman, I have the GOTY Edition, which offers AA on my ATI card (x2,x4,x8). Although, I just leave it off as the game is so dark I can hardly tell a difference with that setting on or off.

m
0
l
a c 124 U Graphics card
July 26, 2011 10:01:28 PM

Turn up the brightness? =P

But yeah I never played Wolverine so I don't know how demanding it is but you might need to edit the config file if there's no options in the menu.
m
0
l
July 28, 2011 8:35:31 AM

Think anyone can help me out there? It seems that the FPS drops, once I do a lunge attack with Wolverine, it causes a 10-15 FPS drop each time. And when he does crazy claw attacks.

Here is part of the text document that allows you to change the settings (Already adjusted it some of it, like motion blur and distortion):

[SystemSettings]
StaticDecals=True
DynamicDecals=True
DynamicLights=True
DynamicShadows=True
LightEnvironmentShadows=True
CompositeDynamicLights=True
DirectionalLightmaps=True
MotionBlur=False
DepthOfField=True
AmbientOcclusion=True
Bloom=True
UseHighQualityBloom=True
Distortion=False
DropParticleDistortion=False
SpeedTreeLeaves=True
SpeedTreeFronds=True
OnlyStreamInTextures=False
LensFlares=True
FogVolumes=False
FloatingPointRenderTargets=True
OneFrameThreadLag=True
UseVsync=True
UpscaleScreenPercentage=True
Fullscreen=True
AllowD3D10=False
SkeletalMeshLODBias=0
ParticleLODBias=0
DetailMode=2
ShadowFilterQualityBias=0
MaxAnisotropy=16
MaxMultisamples=1
MinShadowResolution=32
MaxShadowResolution=512
ShadowFadeResolution=128
ShadowFadeExponent=2.200000

Tested with and without vertical sync, same problems.

I copy paste the entire configuration file if necessary. Just did not want to overload the thread. Tell me if I should post it or not.
m
0
l
a c 376 U Graphics card
July 28, 2011 9:12:09 AM

I would turn off depth of field and ambient occlusion. They make things blurry at a performance hit. It's slightly more realistic maybe but definitely something I would turn off first if having performance issues.
m
0
l

Best solution

a b U Graphics card
July 28, 2011 2:31:25 PM

Shpati said:
Think anyone can help me out there? It seems that the FPS drops, once I do a lunge attack with Wolverine, it causes a 10-15 FPS drop each time. And when he does crazy claw attacks.

Here is part of the text document that allows you to change the settings (Already adjusted it some of it, like motion blur and distortion):

[SystemSettings]
StaticDecals=True
DynamicDecals=True
DynamicLights=True
DynamicShadows=True
LightEnvironmentShadows=True
CompositeDynamicLights=True
DirectionalLightmaps=True
MotionBlur=False
DepthOfField=True
AmbientOcclusion=True
Bloom=True
UseHighQualityBloom=True
Distortion=False
DropParticleDistortion=False
SpeedTreeLeaves=True
SpeedTreeFronds=True
OnlyStreamInTextures=False
LensFlares=True
FogVolumes=False
FloatingPointRenderTargets=True
OneFrameThreadLag=True
UseVsync=True
UpscaleScreenPercentage=True
Fullscreen=True
AllowD3D10=False
SkeletalMeshLODBias=0
ParticleLODBias=0
DetailMode=2
ShadowFilterQualityBias=0
MaxAnisotropy=16
MaxMultisamples=1
MinShadowResolution=32
MaxShadowResolution=512
ShadowFadeResolution=128
ShadowFadeExponent=2.200000

Tested with and without vertical sync, same problems.

I copy paste the entire configuration file if necessary. Just did not want to overload the thread. Tell me if I should post it or not.


Shadows are a real killer for gpu performance as well. You should really have ambient occlusion off as well if your having any performance hit. Lastly I would disable the Depth of field, It's really just a blurred background as though you were looking through a camera lense, what's not focused on is blurry.
Share
a c 124 U Graphics card
July 28, 2011 2:41:23 PM

I agree on DoF and Occlusion. Try DoF off first.
m
0
l
February 26, 2012 11:34:37 PM

Best answer selected by Shpati.
m
0
l
!