I think my computer is under-performing

I got a computer off of ibuypower a few months ago and I'm not too happy with it. I want to know if you think it is under-performing and if there is a way to fix that, or if I need to upgrade. I can't keep steady 60 fps in skyrim on medium settings and I get 45-80 fps in battlefield on all low settings and no AA. Here are my specs:

CPU: AMD Phenom II x4 3.4 GHz OC to 3.8 GHz.
GPU: 2x NVIDIA EVGA GTX 560 2GB in SLI mode.
RAM: Adata 8 GB, 1600 MHz DDR3
Mobo: Gigabyte GA-870A

I really feel like it should be performing better than it is. Is there anything that I can do to help speed up my system?
7 answers Last reply
More about computer under performing
  1. make sure all frour cors are working in task manager, make sure you have the latest graffix drivers
  2. yeah....check your drivers and then also check if your CPU is not bottlenecking the 2 gtx 560

    you might wanna read this whole article to see what i mean.
    http://www.tomshardware.com/reviews/core-i5-fx-6100-overclock-benchmark,3099.html
  3. @kirov, going to read that next.
    @xaira, I have all updated drivers and when I play BF3 all my cores are at about 80-90% usage.
  4. Before Playing Battlefield: http://i.imgur.com/tRFPw.png
    After Playing Battlefield: http://i.imgur.com/VTPDm.png

    As you can see, the meter on the left (My 2nd GPU) has not been utilized at all and my first GPU was only used a little bit. While I was playing, the highest I saw my GPU was at 17%. The game is almost fully relying on my CPU to do the work. Any ideas on how to fix this?
  5. Is sli enabled in the nvidia control panel
  6. also if i want you i would manually enable the fans in the game, also in bios make sure that when you have overclocked that cpu you turn OFF the turbo mode and also CE1 in the dettings and turn ON the manually set each proccessor to on and not auto.

    i have that problem on my back up system for 2 amd systems 1 running the 1090T x6 and the other runing the FX-8150 x8. with with crossfire 2x 6970's in them and i couldnt get more than 70 fps then i changed those settings and boom its went up to 150 on ultra and 80 in eyefinity
  7. Spoony said:
    also if i want you i would manually enable the fans in the game, also in bios make sure that when you have overclocked that cpu you turn OFF the turbo mode and also CE1 in the dettings and turn ON the manually set each proccessor to on and not auto.

    i have that problem on my back up system for 2 amd systems 1 running the 1090T x6 and the other runing the FX-8150 x8. with with crossfire 2x 6970's in them and i couldnt get more than 70 fps then i changed those settings and boom its went up to 150 on ultra and 80 in eyefinity

    I changed the CE1 settings just now but I will need you to tell me how to turn off turbo mode. I don't want to mess anything up.
Ask a new question

Read More

CPUs Computers