Closed Solved

Cpu stopped working after applying arctic silver 5

I built a new computer from new parts and have been having many problems with it. I noticed the temperatures were a
bit high so i decided to remove the thermal paste i put on there initially and reapply with a little more. I used a paper
towel with rubbing alcohol to get rid of the stuff on the heatsink and a q-tip to get rid of the stuff on the cpu.
After i put more of it it on and plugged it all in the led next to the cpu is on. I tried taking a little off, switching power supplies, but the light is still on. The cpu is an intel i7 2600k and i am using arctic silver 5. Im using an asus sabertooth p67 for a motherboard. Is there anything else i can do or is the cpu fried?
9 answers Last reply Best Answer
More about stopped working applying arctic silver
  1. Do you mean the power light is still on or you can't turn on your computer? If the former is the case, check the case wire connections on the motherboard. You may have them in the wrong spot. If the latter is the case, something is shorting out your computer and most likely, it's lint from the paper towel you used. You need to use a lint-free cloth for that instead. Still, check the screws (make sure they don't come in contact with the top of the motherboard) or see if any of the thermal grease may have fallen onto the motherboard upon putting your heat sink and fan back on.
  2. Also make sure the CPU fan is plugged in.
  3. the machine powers up but the light next to the cpu is on meaning there's a problem with that component so the system cant boot. I looked all over the motherboard and cpu and there is only thermal paste on the top of the cpu and slightly on one side. I cleaned it all off the side.
  4. If you over did it and got the paste to ooze out it probably got in the socket on the motherboard and is shorting out.
  5. Is the 4/8 pin CPU power plugged in?
  6. i tried the 4/8pin connector from 2 different psus and im getting the same result
  7. Best answer
    Well if everything is plugged in you probably got paste in the socket and ruined the motherboard.

    Take everything out and bread board it, if it dont turn on time to buy a new motherboard.
  8. Breadboxed it and have the same error. Im hoping the motherboard was the problem because I was having other problems with it earlier anyway. I will be devastated if the cpu is broken. Thanks for the help.
  9. Best answer selected by starghost.
Ask a new question

Read More