Sign in with
Sign up | Sign in
Your question

New ASRock mobo USB problem

Last response: in Motherboards
Share
October 16, 2012 6:54:51 AM

Hey guys, just installed a Z77 Extreme4 ASRock motherboard along with a new i5 and new memory - everything boots up and works fine (But no bootup beep - odd...it's built in but I'm not sure if it's just a setting or something). Anyway, I tried using Sysprep to tell my HD with windows 7 on my old EVGA motherboard to basically forget all the drivers and such so I could cleanly install my ASRock. Welp...don't ever do this because it doesn't work. I go to boot up and it tells me it can't launch and will finish setup after reboot. Ad infinitum...I tried using the Windows 7 disc to repair it, but here's the interesting bit - my USB mouse and keyboard which work FINE when I'm in UEFI and operating the other motherboard menus all die as soon as it shows the Windows 7 setup screen.

So I pulled out a PS/2 keyboard to use (Thank goodness the motherboard at least has ONE PS/2) - but I'm seriously concerned, why is this happening? Please don't tell me this is signs the motherboard is bad...I just bought it, but I don't want to have to go through that RMA process. I could've imaged my hard drive on my new 1 TB...if it wasn't head clicking and I just RMA'd it. Everything seems to work fine until I get to that cursed Windows 7 disc setup screen. Is it possible this is just an issue that will resolve itself after I fix my Windows 7 install, or is this new motherboard already defective? I have all USB legacies and versions enabled in UEFI. My USB devices are a USB keyboard (Logitech G15), USB mouse (G500), and a MIDI keyboard which is powered off (M-Audio Oxygen 61).

Also, if anyone has any ideas on a way to salvage my Windows 7 install please let me know. I have ways to access the drive from other PCs so I can attempt repair in that manner. I really do not want to format the drive if avoidable, I purposely didn't buy an SSD because it would require a format and reinstall. If I have to do this, not really a benefit to me having not done that in the first place...
a b V Motherboard
October 16, 2012 7:06:25 AM

have you installed the usb drivers?
October 16, 2012 7:53:40 AM

I can't really install anything, when I try to boot into my Windows 7 drive it tries its Sysprep setup and fails. I have a secondary drive with XP on it, when I tried booting off of it I got a split second blue screen then it was gone. Clearly whatever is wrong, the USB works BEFORE it gets to this point - but when Windows tries to start then it just dies. The only disc I have for the ASRock is a driver/utility disk which I imagine doesn't do anything if I try to boot off it - but I don't recall trying it so I'll see after backing up some data if that does anything.
Related resources
a b V Motherboard
October 16, 2012 7:55:26 AM

id try a fresh install if i were u
October 16, 2012 8:45:32 AM

Well I'm not too worried about it if there's no other way at this point, but I'm more concerned about the USB issue. I'd like to figure out if that's the motherboard at fault or what - I need to RMA immediately if it is.
a b V Motherboard
October 16, 2012 8:56:34 AM

have you tried different usb ports? i have 3 different sets on mine and they all function differently

edit: some hard drives work on some and not others, some require usb drivers after install, some require other usb drivers after install
a b V Motherboard
October 16, 2012 11:24:36 AM

I have the same mobo and once my mouse/keyboard did not work on start up. I unplugged them and plugged them back in then they worked. Worth a shot.
!