Sign in with
Sign up | Sign in
Your question
Solved

[SOLVED]Hard drive and DVD drive not seen unless booted through BIOS

Last response: in Motherboards
Share
October 16, 2012 6:37:03 PM

I'm going to basically copy/paste what I submitted to ASUS tech support, hoping that someone here has an idea of what's going on.
Specs:

Asus Sabertooth X79 mobo
Intel i7-3930k
G Skill ripjaw ddr3ram, 16 GB
Corsair force series SSD
Western Digital caviar black HD *
EVGA GTX 680
Asus Blu Ray Writer - BW-12BD1ST (I think) *

*- Drives not recognized.

I am having an issue with my new PC, which was just built Sunday night (10/14). It is 100% reproducible.
On a new installation of Windows, Windows fails to recognize the following drives:
Asus Blu Ray writer 12x, (BW-12B1ST I believe is the model) Western Digital 1 Tb Caviar Black HDD
On any boot, Windows fails to see these two drives.

However, they are visible in the BIOS, and sometimes in the device manager. The only way I can get Windows to see them is by opening the BIOS at boot. I do not need to change any settings the BIOS. No matter what I do there, Windows will then see the drives once I leave the BIOS and boot Windows. It does not matter if I exit and discard changes or exit save changes (even if I don't make any), the devices will then show. However, I have to open the BIOS for Windows to see them.


However, as soon as I reset or cold boot the computer, the drives will disappear once again. It is a 100% reproducible problem with these steps.

I have tried moving the drives to different SATA ports on the motherboard. The drivers have been installed for the hard drive, SATA controller, Intel Chipset (all from the X79 disc) and the firmware upgraded on the Asus Blu ray drive.

I have tried to change the boot priority. The BIOS is the latest version.

I do not believe that faulty SATA cables can be the problem because of how it can be reproduced in this way.

Is there a setting the BIOS I'm missing? It's almost as if the drives don't get configured before booting to Windows unless I open the BIOS.

Anyone have an idea?

More about : solved hard drive dvd drive booted bios

a c 102 Ĉ ASUS
a c 493 V Motherboard
October 16, 2012 7:39:48 PM

Have you got all 3 SATA controllers set to AHCI mode? I assume they are all ENABLED. Which of the 3 SATA controllers are you using for which drives?
The X79 6GB/s (Brn ports)
The X79 3GB/s (Blk ports)
The Marvel 6GB/s (Gry ports)

As for the optical drive, can you boot to the drive?
m
0
l
October 16, 2012 9:52:41 PM

All are enabled and set to AHCI.

The drives are connected to the following SATA ports:

Corsair SSD - Marvell 6G
WD HDD - Intel 3G
Blu Ray - Intel 3G

I was thinking of trying to move the Corsair to the Intel 6G just so they are all on Intel. The Marvell SATA controllers have been installed. I don't feel like that should be making the difference here.

I can boot to the optical drive if I set it as the top option in boot priorities. The drive works. I installed Windows and the X79 drivers from it, after all.

I'm at work right now, I can't give anything definitive on actions for a few more hours until I get home, but I'm thinking of setting a boot delay in the BIOS. It's almost as if Windows boots before the other drives can be initialized.
m
0
l
Related resources
a c 102 Ĉ ASUS
a c 493 V Motherboard
October 16, 2012 11:52:50 PM

Somewhat off topic, but you never want to connect your SSD to the Marvel ports. That is the main drive that needs to be connected to the fastest ports: the 6GB/s SATA 3, X79 ports. The HDD also, although it's not as important. The optical drive is the slowest and can be connected to any port. If you're interested, here is an excellent tutorial for installing Windows 7 on a SSD:
http://www.overclock.net/t/1156654/seans-windows-7-inst...
(Be sure to click open the links in the discussion for the good stuff. I highly advise you re-install Win7 using this tutorial (and moving the to the Intel SATA ports) when using a SSD. It will help avoid pitfalls you wouldn't normally have with a regular HDD installation.

Back to your original issue... If your HDD is used as a secondary drive, be sure to go to Ctl Pnl/Adnin Tools/Comp Mngmt/Disk Mngmt and see if you have to manually make your drive active. Sometimes Windows won't do it automatically. It will not recognize it until it is made active.

Also, be sure your SATA contoller is set to ENHANCED if using AHCI mode, and not COMPATIBLE.
m
0
l
October 16, 2012 11:59:18 PM

I'll look into that SSD tut when I get home, thanks.

But nope, I've initialized the drive in the disk manager already. It's been partitioned and is good to go anytime after I go into the BIOS. Since both drives disappear after a reset, that doesn't seem to be the solution.

How dependable is the backwards compatibility of SATA? I moved the HDD to the X79 3G/s because I wasn't sure if it could make use of the 6G, so it might as well be on the 3.

Thanks for the input.
m
0
l

Best solution

a c 102 Ĉ ASUS
a c 493 V Motherboard
October 17, 2012 12:08:52 AM

Yes, I forgot you already said you were able to access the drives after jumping thru some hoops. So obviously it was active. Duh!

Backwards compatibility should be just as good as with any HDD. If Asus doesn't get back to you in good time, I would do a clean install of the O/S with the all drives on the Intel SATA III ports... using the tutorial.
Share
October 17, 2012 3:12:31 AM

SOLVED.

As usual, the simplest explanation wins out. I swapped the SSD from a Marvell port onto the Intel 6G/S, and now the drives show on consecutive boots with no need to enter the BIOS.

Now, I'm still not sure that this is not a motherboard defect, because I would expect that I should be able to mix and match Intel/Marvell ports on my board if I so choose. Otherwise, why would they be there?

Regardless, the issue is solved for me. I don't expect that I will reach the number of expansion drives that it would take where I would need to utilize the Marvell ports again and make that an issue. It really seems like this should have been a non issue. However, I'm happy.
m
0
l
October 17, 2012 3:59:24 PM

Best answer selected by myukes.
m
0
l
a c 102 Ĉ ASUS
a c 493 V Motherboard
October 17, 2012 6:50:14 PM

Congrats! It's never a non-issue when it is solved and knowledge is gained.
m
0
l
October 17, 2012 9:32:14 PM

Thanks for your help!
m
0
l
!