Sign in with
Sign up | Sign in
Your question

GA-Z77-D3H not detecting Sapphire Radeon 7850

Last response: in Motherboards
Share
October 18, 2012 5:49:32 AM

I asked this question in the graphics section but I got no response. I'm not sure whether it's a motherboard or graphics card issue.

I have a Sapphire Radeon 7850 which the GA-Z77-D3H motherboard won't recognize at all. It doesn't show up in the device manager and when I install the ATI drivers it installs 'with errors' and I have tried setting the BIOS to use PEG so it picks up the graphics card but that doesn't work either. Basically the card does not exist. Funny thing is my mate has the exact same board and has the exact same problem when I tried the card in his computer.

To check if the PCI-E slot was the issue I tested a Sapphire 6950 which worked fine in his computer but for some reason had a few issues with mine. When I booted the computer a red light turned on on the back of the 6950 and it wouldn't work. I wiggled it around a bit and the light turned off, I reset my computer and then the card worked fine. The 6950 draws more power than the 7850 so it can't be the power supplies that are the issue.

I thought then maybe that the 7850 was the problem but it works perfectly in my old system running an ASUS P6T-SE mother board.

It seems to me that the GA-Z77-D3H has an issue with the 7850. I don't have any other graphics cards to test.

Any help would be greatly appreciated.
a c 125 V Motherboard
October 18, 2012 8:03:50 AM

Sounds like the slot in your MB is bad.
m
0
l
a b V Motherboard
October 19, 2012 2:44:21 AM

both PCIe on Z77-D3H faced same problem with that VGA?
m
0
l
Related resources
a b V Motherboard
October 19, 2012 2:59:07 AM

Could be a compatability issue, but it could be your pcie slot is messed up. Isn't there a latch to hold the card in? Make sure its all the way in and latch it. Have you tried both pcie power connectors?
m
0
l
October 19, 2012 4:55:49 AM

Cheers for the responses guys.

Yea both boards won't recognize the 7850 and both boards recognize the 6950. And yes I made sure that the card is pushed in and latched properly and tried all the different PCI-E power connectors ;) .

It just perplexes me that one graphics card works while the other doesn't and yet the one that doesn't work, does work on a different motherboard. All pieces are functioning as they should individually but when the GA-Z77-D3H is paired with the 7850 problems occur.

I think I'll look for a bios update and see if that helps at all.
m
0
l
a b V Motherboard
October 22, 2012 2:49:23 AM

also check vga bios
m
0
l
October 22, 2012 3:07:20 AM

BerylLee said:
also check vga bios


Interesting I didn't realize that graphics cards had their own bios. How do I check it or update it??
m
0
l
a b V Motherboard
October 23, 2012 2:46:07 AM

find vga vendor website and download bios and tool for the update. it depends on vga vendor.
m
0
l
February 19, 2013 1:54:20 PM

In bios there is an option below system health go there and there is an option named like (gpu gen)
and from it choose gen 3. hope it works
m
0
l
!