Closed Solved

Why is my i5 2500k at 1.5ghz?!

when i was done building the computer, assassins creed revelations was working fine. when i check CPU Z and my asrock tuner it says its at 1.5ghz and assassins creed is lagging now. my multiplier is at x16 and i havent touched anything. whats going on?!

SPECS:
ASROCK extreme 3 gen 3 mobo
gigabyte 6870 1gb
500gb WD sata 6 gb/s
core i5 2500k with stock cooler (3.33ghz)

screen shot attached ...... http://i44.tinypic.com/161mfza.png

PLEASE HELP :fou:
16 answers Last reply Best Answer
More about 2500k 5ghz
  1. Happen to read through the stickies?
    Why is my CPU not showing correct speeds?

    Run prime 95 to load it up and the speed should jump up to 3.3GHz. If it doesn't go up then you have a problem, otherwise its just speedstep kicking in when you are at idle to save power and isn't the source of your lag.
  2. hunter315 said:
    Happen to read through the stickies?
    Why is my CPU not showing correct speeds?

    Run prime 95 to load it up and the speed should jump up to 3.3GHz. If it doesn't go up then you have a problem, otherwise its just speedstep kicking in when you are at idle to save power and isn't the source of your lag.


    NOTHING changed:( when i ran assassins creed i would go back and see the clock speed and it would be the same. heres another screenshot. what else should i try? should i reinstall windows? should i push the clear cmoss button? who should i contact? this is driving me nuts.

    http://i42.tinypic.com/2enpxti.png
  3. hunter315 said:
    Happen to read through the stickies?
    Why is my CPU not showing correct speeds?

    Run prime 95 to load it up and the speed should jump up to 3.3GHz. If it doesn't go up then you have a problem, otherwise its just speedstep kicking in when you are at idle to save power and isn't the source of your lag.


    im sorry here is the right picture http://imageshack.us/photo/my-images/841/primer.png/
  4. Best answer
    Boot into bios and change multiplier to 33? :O
  5. reset your bios
  6. I have an Asrock Extreme 3 Gen 3 as well, but that problem never happened to me. Instead of using the Asrock Overclocking Utility, use the BIOS instead. It is a UEFI so it is really easy to look at, navigate, and understand.

    Were you playing around with overclocking it at all? Maybe you changed a setting.

    What BIOS version are you using? It comes stock with 1.1 I believe? I am using 1.2 right now and it is working fine. Here is a link to it's newest drivers.

    http://www.asrock.com/mb/download.asp?Model=Z68%20Extreme3%20Gen3
  7. that is very amazing core i5 2500k ar 1.5ghz replace this processor if u can
  8. pell380 said:
    that is very amazing core i5 2500k ar 1.5ghz replace this processor if u can


    Why would he do that? All he needs to do is up the multiplier!
  9. check your power plan in controlpanel and use high performance plan
  10. The most logic answer of all is upped the multiplier.
  11. pell380 said:
    that is very amazing core i5 2500k ar 1.5ghz replace this processor if u can


    Its at 1.595 which is 1.6Ghz with the slightest of underclocks on the fsb/bclk, which is precisely where it should be when idling.

    The question is why does it not stop idling.

    Power plan is a good option, in fact the only one I can think of, a bios reset might be a good thing to do, but its unlikely to be a problem in my opinion.
  12. Check your power options. Make sure its set to Balanced. (High power makes it stay at highest Multipler, Energy saving keeps it lowest Multipler.)
  13. I know with my amd based systems there are some drivers you need to install.

    It's a link to Intel® Processor Identification Utility

    http://www.intel.com/support/processors/tools/piu/sb/CS-014921.htm

    Intel claims that the intel cpu driver is included with windows since winxp.
  14. I've got the same problem here with an 2500K an Intel DH67BL board.
    Please let me know if you find a solution.
  15. Best answer selected by nickazzo123.
Ask a new question

Read More

CPUs Intel i5