Sign in with
Sign up | Sign in
Your question
Solved

A disk read error occured

Last response: in Motherboards
Share
October 22, 2012 12:16:35 AM

Hello! I have a Dell Dimension XPS T650r tower that I'm having trouble getting to boot from a hard drive. The tower came with Windows XP loaded from the previous owner on its 20 GB hard drive. I wanted a newer operating system and a larger hard drive so I threw in an old PATA 40GB drive that I had. I installed Windows Vista Ultimate SP2 x86. The installation was smooth, but upon the mid-installation reboot I received the BIOS error: "A disk read error has occured. Press Ctrl + Alt + Del to restart."

I went through the BIOS looking for possible hangups, checked boot sequence (and other relevant settings) could not get it to boot. Knowing old PATA drives are finicky with their cable positions and jumper pins, I tried eliminating unnecessary devices and toggled all possible combinations of jumper pins. I tried Single with no slave, Master / Slave, and cable select. I tried these combinations on both of the 2 IDE controllers, and I tried all combinations with an 80-wire ribbon and then again with a 40-wire ribbon (minding the transposition of cable select drives on 40-wire), also tried 32GB LIMIT jumper. The BIOS would always "see" the hard drive, but the same error was persistent: "A disk read error has occured. Press Ctrl + Alt + Del to restart." I chkdsk the hard drive on another computer, no errors. I plugged the original XP hard drive back into the tower, and it booted into XP. I format 20 GB (XP) hard drive, install Vista on it without error, until reboot, where the familiar "A disk read error has occured. Press Ctrl + Alt + Del to restart." error occurs, this time on a different drive. I try a third, definitely functional hard drive, install Vista, and receive the same error on THAT drive, in the same spot during installation reboot.

All 3 drives are accessible from a live Linux DVD-ROM boot, and show no errors. I attempt to install Linux Mint 13 Maya from live OS, installation is successful, reboot produces same error as above. I'm not sure what to try next. I can't figure out what the problem is. If you have any ideas or are able to spark a new train of thought, I would be very grateful!

Also, I realize you may need additional information. Please ask and I will respond.
a c 155 V Motherboard
October 22, 2012 1:41:49 AM

did you check if that xps t650r could handle vista check this on dell with the service tag
m
0
l
Related resources

Best solution

October 22, 2012 4:02:29 AM

My money is on your DVD drive being bad. I would try with a different drive if you can find one. If it's getting caught up in the same spot each time (and given the tests that you've already done) it's reasonable to assume that it's an error with the transfer of files or with the controller or port on the mobo itself.
Share
October 22, 2012 4:32:51 PM

Thank you for your response, benji720. I will test the IDE controllers, the IDE ports, and the DVD ROM drive. I will update this thread when I have results.
m
0
l
November 20, 2012 1:32:01 PM

I cut my losses on this machine and parted it. I never reached a resolution.
m
0
l
November 20, 2012 1:32:14 PM

Best answer selected by ECHOSIDE.
m
0
l
!