Sign in with
Sign up | Sign in
Your question
Closed

HD 6990 Micro-stuttering

Last response: in Graphics & Displays
Share
August 1, 2011 12:23:33 AM

Hi, I just got a HD 6990 and tested it on a few games (Crysis, Crysis Warhead, Crysis 2, Metro 2033, BF:BC2, Battlefield 3 Alpha, TF2, and ARMA 2). Out of those games, Crysis, Crysis Warhead, and Metro 2033 stuttered and felt choppy at times. Metro was fine as long as it was above 60 FPS, but if it fell below that, it became really choppy. I have a Intel i5 2500k and am using 11.7 drivers. Any help would be greatly appreciated.

More about : 6990 micro stuttering

a b U Graphics card
August 1, 2011 12:41:23 AM

11.7 should be the newest one. Are you running Crysis 2 at Direct11 setting? If so, you won't really get smooth playback unless you were to SLI/crossfire with the 580 or the ATI counterpart.
August 1, 2011 12:45:22 AM

DX11 is broken on all AMD cards I think, when I tested it I got 26 FPS... so I just played it without DX11 and it worked perfectly fine. On the games that I'm experiencing stuttering on, they appear to have a high FPS, but feel choppy which leads me to believe it is from microstutter because it is a dual GPU card. Although I haven't really heard to many issues about the HD 6990 and microstutter.
Related resources
a c 216 U Graphics card
August 1, 2011 1:06:09 AM

Crysis 2 ran smooth as can be on my 6950's in crossfire with the Dx11 patch at max on a 1920x1200 resolution. A 6990 should as well.

Btw, what resolution are you playing at?
August 1, 2011 1:29:02 AM

1920 x 1080. I actually just recently had a pair of 6950's and they barely ran Crysis 2 on DX11 either. Either way, i'm more concerned with the other games I listed and their stuttering problems. Is it possible if I put the card in another slot that it can fix any of my problems?
a c 216 U Graphics card
August 1, 2011 1:30:55 AM

How much ram do you have? It seems you are having other issues if you are having trouble with two 6950's and the 6990 with all those games. Did you turn on SSAA or MLAA within the CCC?

Are you having some random little hickups, like it's loading stuff, or is this more constant? What does your FPS look like. Have you check GPU-Z and or MSI Afterburner for clock speeds?
a c 216 U Graphics card
August 1, 2011 1:34:07 AM

Oh, and what brand are your cards? I've had issues with ASUS's SmartDoctor causing horrible FPS.
August 1, 2011 1:47:01 AM

I have 8 gbs of RAM. With Crysis and Crysis Warhead its constant, with Metro its usually when enemies start to appear or when my FPS dips below 60. I'm not sure what brand it is, but if I were to guess I'd say MSI.
a c 216 U Graphics card
August 1, 2011 1:48:41 AM

I wonder if you have a ram issue. I've seen these types of problems with bad ram. Since the problem was with 6950's and a 6990, I'm going to figure the problem is not the video cards.
August 1, 2011 1:49:06 AM

Also, my FPS was around 50-80 for Crysis, and a bit higher than that for Warhead. I also forgot to mention that if I use vsync in crysis/crysis warhead, the FPS caps at 24 FPS, is that related to this issue in anyway?
August 1, 2011 1:50:33 AM

The 6950's worked perfectly fine, I'm only experiencing it on the 6990. Also, the 6990 is in a different PC then the one with the 6950's.
a c 216 U Graphics card
August 1, 2011 1:51:16 AM

Oh...

Try right clicking the desktop and go to screen resolution, then click advanced settings and choose the Monitor tab. Make sure the screen refresh rate is 60 or higher.

If you are using a CRT, it's possible you chose too high a resolution for the monitor.
August 1, 2011 2:03:30 AM

My refresh rate was 59, was that the problem? Also, my screen max resolution is 1920 x 1080, even thought it doesn't use the whole screen, so I use over-scan to fill up the rest.
a c 216 U Graphics card
August 1, 2011 2:17:47 AM

59hz shouldn't cause 24 FPS with vsync. When you game, do you have a browser open by chance? I've seen odd problems with the browser open as well. One such problem is if a video is on the screen (not even running), it has been known to screw with graphics clocks.
August 1, 2011 3:11:16 AM

I tried it without a browser and it made no difference
a b U Graphics card
August 1, 2011 3:32:28 AM

had the same problem with crossfire 6870s through several drivers way before the 11 era and abondoned them, also what are your full system specs? maybe a slow hdd not able to feed textures fast enough? your cpu should certainly be able to handle it, also what psu do you have?
a c 216 U Graphics card
August 1, 2011 3:40:48 AM

I never used the 11.7 drivers, but I had no problems with 11.6 or 11.5.
August 1, 2011 3:43:10 AM

The HDD is 1TB SATA-II and my PSU is a SolyTech 800W. Bystander, did you have problems with 11.3 drivers? I rolled back to 11.3 and it didn't fix it.
a c 216 U Graphics card
August 1, 2011 3:54:15 AM

I never really had problems with any drivers. As a result, I didn't always update to the latest. I don't recall if I used 11.3 or not.
a c 216 U Graphics card
August 1, 2011 3:55:10 AM

Have you looked at GPU-Z to make sure it's running at the correct bus interface speed?
August 1, 2011 4:00:54 AM

It says Bus Interface: PCI-E 2.0 x 16 @ x 16 2.0
a b U Graphics card
August 1, 2011 5:54:22 AM

well what make and model hdd do you have honestly i noticed a difference when I went from a 1 tb sata II shitty toshiba deskstar as my main storage device to a 500 gb wd caviar black sata 6 gbps, im not saying that this was totally the culprit but definatley a contributing factor imo/
August 1, 2011 6:10:54 AM

It only happens when I use both GPU's, if I play it windowed there is no stuttering but the FPS does dip because it is only using 50% of the card. If it were because of my HDD, wouldn't it affect it even when using one of it's GPU's?
a c 216 U Graphics card
August 1, 2011 6:15:54 AM

Have you check to see if their are any bios updates for your motherboard?

You may also want to open up CCC Overdrive and turn Powertune up to 10% or higher.
August 1, 2011 6:28:56 AM

Hmm, I'm using stock BIOS for my mobo I think, can that really be causing this? I'll see if there are any updates and hopefully that works.
a c 216 U Graphics card
August 1, 2011 6:33:59 AM

heatfanman said:
Hmm, I'm using stock BIOS for my mobo I think, can that really be causing this? I'll see if there are any updates and hopefully that works.


I've seen BIOS updates include crossfire and SLI fixes. It's possible.
August 1, 2011 7:05:39 AM

I'm trying to update my BIOS, but Asus seems to not want me to. I have a P8P67-M and I downloaded the most recent bios and I can't find a way to apply it. It's a ROM File and am not really sure what to open it with. They had an update tool, but it keeps saying that it doesn't work with my version of windows (64bit).
August 1, 2011 8:56:11 AM

I found out how to update my bios and updated them, but it didn't really help
August 1, 2011 2:42:46 PM

sounds like the game gets treated as video, and your TV(i suppose its a hdtv since you talked about underscan) if vsync on makes your fps lock at 24hz, well that means either the tv is in 24fps mode for movies, or the video card is not really complying and treating it as video.

either video card or screen is treating the game as video, first thing you could try is another resolution, something like 640x480, the tv should support that just fine, it will look like ***, but it should show you if it's the tv or video card coursing the problem.
a b U Graphics card
August 1, 2011 4:08:28 PM

well i will chalk it up to the crappy nature of crossfire drivers
a c 271 U Graphics card
August 1, 2011 6:42:07 PM

wintermint said:
11.7 should be the newest one. Are you running Crysis 2 at Direct11 setting? If so, you won't really get smooth playback unless you were to SLI/crossfire with the 580 or the ATI counterpart.


Nonsense, I was getting a smooth 60 - 70fps with SLi'd GTX560Ti's.
August 1, 2011 8:19:10 PM

I went into crysis and 640x480 wasn't an option, so I tried using 800x600 and enabled vsync. It made the game seem like it was shaking, and the fraps said it was 24 FPS but it felt like it was faster than that, even though the game was shaking.
a c 216 U Graphics card
August 1, 2011 8:42:15 PM

Do you happen to have a monitor you could try with your setup? 24 FPS with v-sync on is hz that movies play at. Maybe your tv/monitor is messing things up or at least we can pinpoint what we are trying to solve.
August 1, 2011 9:11:22 PM

have you tried disableing V-Sync
I use an NVidia GTX 580 and did not have any issues with Crysis 2 untill I turned on V-Synce and I am running the DX11 upgrade patch with high resolution textures.

Try turning off V-Sync and see what happens. I know Nvidia recommends you run games without V-Sync enabled, maybe AMD is the same way.
August 2, 2011 1:30:59 AM

I don't think my monitor is exactly the problem because I used the same monitor for the 2 6950's
a c 216 U Graphics card
August 2, 2011 1:45:32 AM

heatfanman said:
I don't think my monitor is exactly the problem because I used the same monitor for the 2 6950's


Didn't you say you had the same problem with the 6950's? If so, it's a good indication it's something other than the cards.

Best solution

August 2, 2011 2:45:00 AM
Share

if fraps said 24fps at 800x600 it's probably not the tv IF you didn't use gfx scaling, you need to feed the tv a non 1080 resolution which is used on bd for 24hz movie playback. The shaking however could indicate it was indeed feeding 800x600 to the tv(bad tv scaler or something dno)

the problem MUST lie with the graphics card then. Try disabling crossfire, if that's no avail, try a clean driver install, maybe even an older or newer driver. Sorry if you tried those two suggestions I haven't read all posts :) 
August 2, 2011 5:54:28 AM

My HD 6950's were totally fine, no stuttering from them... which is why the 6990 stuttering confuses me so much because it's basically 2 6950's in one card. The 6990 is in a totally different PC than 6950's were though, the only thing in common is the monitor, mouse, and keyboard. And I'm I don't think I have GPU scaling enabled so I'll try that. Also, you can't disable crossfire in CCC for the 6990, but you can play games in windowed mode (which doesnt stutter, but only uses half my card). I wiped my driver, installed older ones and it didn't really fix anything.
a c 216 U Graphics card
August 2, 2011 6:27:00 AM

Oh, I misread your earlier post, or remembered it wrong. In that case, something does seem wrong with the card. Look at GPU-Z and make sure it shows that it's crossfire enabled.
August 2, 2011 6:27:21 AM

Ok, Wow! I enabled GPU Scaling and Crysis is now extremely smooth! That is incredible :D  :D  :D  ! I don't know why, but I'm getting way more frames than I did with my 6950's(I used to get 40-50's), and know there is no stuttering and vsync works now too :D  . Thanks for the help everyone, I was starting to get worried that this was a problem I couldn't fix :D 
August 2, 2011 6:28:22 AM

Best answer selected by heatfanman.
a c 271 U Graphics card
August 2, 2011 8:29:37 AM

This topic has been closed by Mousemonkey
!