Edit File Type

Archived from groups: microsoft.public.windowsxp.customize (More info?)

I created a menu choice on the popup menu for folders to
go to that directly to that directory in a DOS window,
which is a very handy thing. Trouble is the first time I
did it, I made a typo in the Action name and now I can't
get rid of it. I am logged in with admin priveleges, but
when I select the Action in the Edit File Type dialog,
both the Edit and Remove buttons are always disabled. I
also tried logging in as the true administrator to the
machine, but the buttons were still disabled. Does anyone
know any other way of getting rid of menu choices on the
popup menu for a folder? There are other commands I'd
like to get rid of as well. Thanks.

Natasha

PS Here is how you add the command to the popup menu:

1. Tools > Folder Options > File Types

2. Click Folder file type.

3. Click Advanced button.

4. Click New and configure:

Action: Command Prompt Here

Application Used to Perform Action: c:\windows\system32
\cmd.exe /K cd
5 answers Last reply
More about edit file type
  1. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Natasha wrote:
    > I created a menu choice on the popup menu for folders to
    > go to that directly to that directory in a DOS window,
    > which is a very handy thing. Trouble is the first time I
    > did it, I made a typo in the Action name and now I can't
    > get rid of it. I am logged in with admin priveleges, but
    > when I select the Action in the Edit File Type dialog,
    > both the Edit and Remove buttons are always disabled. I
    > also tried logging in as the true administrator to the
    > machine, but the buttons were still disabled. Does anyone
    > know any other way of getting rid of menu choices on the
    > popup menu for a folder? There are other commands I'd
    > like to get rid of as well. Thanks.
    >
    > Natasha
    >
    > PS Here is how you add the command to the popup menu:
    >
    > 1. Tools > Folder Options > File Types
    >
    > 2. Click Folder file type.
    >
    > 3. Click Advanced button.
    >
    > 4. Click New and configure:
    >
    > Action: Command Prompt Here
    >
    > Application Used to Perform Action: c:\windows\system32
    > \cmd.exe /K cd

    Natasha

    Or you could use the Microsoft PowerToy, "Open command window here". <bg>

    --
    Ronnie Vernon
    Microsoft MVP
    Windows Shell/User

    Please reply to the newsgroup so all may benefit.
    http://www.dts-l.org
    http://www.mvps.org
  2. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Type regedit in Start Run and navigate to

    HKEY_CLASSES_ROOT\Directory\shell

    If after adding cmd to directories (known as File Folder in Filetypes - not all folders can have a command prompt, eg My Computer) the default command has changed type in Start Run
    regsvr32 /i shell32
    --
    ----------------------------------------------------------
    'Not happy John! Defending our democracy',
    http://www.smh.com.au/articles/2004/06/29/1088392635123.html

    "Natasha" <anonymous@discussions.microsoft.com> wrote in message news:46f501c4734e$ac730940$a401280a@phx.gbl...
    > I created a menu choice on the popup menu for folders to
    > go to that directly to that directory in a DOS window,
    > which is a very handy thing. Trouble is the first time I
    > did it, I made a typo in the Action name and now I can't
    > get rid of it. I am logged in with admin priveleges, but
    > when I select the Action in the Edit File Type dialog,
    > both the Edit and Remove buttons are always disabled. I
    > also tried logging in as the true administrator to the
    > machine, but the buttons were still disabled. Does anyone
    > know any other way of getting rid of menu choices on the
    > popup menu for a folder? There are other commands I'd
    > like to get rid of as well. Thanks.
    >
    > Natasha
    >
    > PS Here is how you add the command to the popup menu:
    >
    > 1. Tools > Folder Options > File Types
    >
    > 2. Click Folder file type.
    >
    > 3. Click Advanced button.
    >
    > 4. Click New and configure:
    >
    > Action: Command Prompt Here
    >
    > Application Used to Perform Action: c:\windows\system32
    > \cmd.exe /K cd
  3. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Hmm. Not quite sure what your telling me to do. When I
    navigate to that key, shell Type is REG_SZ and Data is
    none. Under shell is find and under find are other
    entries. What to do? Thank you!

    Natasha

    >-----Original Message-----
    >Type regedit in Start Run and navigate to
    >
    >HKEY_CLASSES_ROOT\Directory\shell
    >
    >If after adding cmd to directories (known as File Folder
    in Filetypes - not all folders can have a command prompt,
    eg My Computer) the default command has changed type in
    Start Run
    >regsvr32 /i shell32
    >--
    >----------------------------------------------------------
    >'Not happy John! Defending our democracy',
    >http://www.smh.com.au/articles/2004/06/29/1088392635123.ht
    ml
    >
    >"Natasha" <anonymous@discussions.microsoft.com> wrote in
    message news:46f501c4734e$ac730940$a401280a@phx.gbl...
    >> I created a menu choice on the popup menu for folders
    to
    >> go to that directly to that directory in a DOS window,
    >> which is a very handy thing. Trouble is the first time
    I
    >> did it, I made a typo in the Action name and now I
    can't
    >> get rid of it. I am logged in with admin priveleges,
    but
    >> when I select the Action in the Edit File Type dialog,
    >> both the Edit and Remove buttons are always disabled.
    I
    >> also tried logging in as the true administrator to the
    >> machine, but the buttons were still disabled. Does
    anyone
    >> know any other way of getting rid of menu choices on
    the
    >> popup menu for a folder? There are other commands I'd
    >> like to get rid of as well. Thanks.
    >>
    >> Natasha
    >>
    >> PS Here is how you add the command to the popup menu:
    >>
    >> 1. Tools > Folder Options > File Types
    >>
    >> 2. Click Folder file type.
    >>
    >> 3. Click Advanced button.
    >>
    >> 4. Click New and configure:
    >>
    >> Action: Command Prompt Here
    >>
    >> Application Used to Perform Action: c:\windows\system32
    >> \cmd.exe /K cd
    >.
    >
  4. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Look under Folder rather than directory then. All directories are folders but not all folders are directories (eg My Computer and Control Panel). Therefore a file system command should have been put under Directory (known as File Folder in Filetypes dialog) as there is no directory if you choose Command Prompt here for My Computer.

    Commands for Directories are added together from AllFileSystemObjects (all files and directories), Folders, and Directory.
    --
    ----------------------------------------------------------
    'Not happy John! Defending our democracy',
    http://www.smh.com.au/articles/2004/06/29/1088392635123.html

    <anonymous@discussions.microsoft.com> wrote in message news:487c01c47353$a8c26b10$a501280a@phx.gbl...
    > Hmm. Not quite sure what your telling me to do. When I
    > navigate to that key, shell Type is REG_SZ and Data is
    > none. Under shell is find and under find are other
    > entries. What to do? Thank you!
    >
    > Natasha
    >
    > >-----Original Message-----
    > >Type regedit in Start Run and navigate to
    > >
    > >HKEY_CLASSES_ROOT\Directory\shell
    > >
    > >If after adding cmd to directories (known as File Folder
    > in Filetypes - not all folders can have a command prompt,
    > eg My Computer) the default command has changed type in
    > Start Run
    > >regsvr32 /i shell32
    > >--
    > >----------------------------------------------------------
    > >'Not happy John! Defending our democracy',
    > >http://www.smh.com.au/articles/2004/06/29/1088392635123.ht
    > ml
    > >
    > >"Natasha" <anonymous@discussions.microsoft.com> wrote in
    > message news:46f501c4734e$ac730940$a401280a@phx.gbl...
    > >> I created a menu choice on the popup menu for folders
    > to
    > >> go to that directly to that directory in a DOS window,
    > >> which is a very handy thing. Trouble is the first time
    > I
    > >> did it, I made a typo in the Action name and now I
    > can't
    > >> get rid of it. I am logged in with admin priveleges,
    > but
    > >> when I select the Action in the Edit File Type dialog,
    > >> both the Edit and Remove buttons are always disabled.
    > I
    > >> also tried logging in as the true administrator to the
    > >> machine, but the buttons were still disabled. Does
    > anyone
    > >> know any other way of getting rid of menu choices on
    > the
    > >> popup menu for a folder? There are other commands I'd
    > >> like to get rid of as well. Thanks.
    > >>
    > >> Natasha
    > >>
    > >> PS Here is how you add the command to the popup menu:
    > >>
    > >> 1. Tools > Folder Options > File Types
    > >>
    > >> 2. Click Folder file type.
    > >>
    > >> 3. Click Advanced button.
    > >>
    > >> 4. Click New and configure:
    > >>
    > >> Action: Command Prompt Here
    > >>
    > >> Application Used to Perform Action: c:\windows\system32
    > >> \cmd.exe /K cd
    > >.
    > >
  5. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Great! That worked! Thank you so much.

    Natasha

    >-----Original Message-----
    >Look under Folder rather than directory then. All
    directories are folders but not all folders are
    directories (eg My Computer and Control Panel). Therefore
    a file system command should have been put under Directory
    (known as File Folder in Filetypes dialog) as there is no
    directory if you choose Command Prompt here for My
    Computer.
    >
    >Commands for Directories are added together from
    AllFileSystemObjects (all files and directories), Folders,
    and Directory.
    >--
    >----------------------------------------------------------
    >'Not happy John! Defending our democracy',
    >http://www.smh.com.au/articles/2004/06/29/1088392635123.ht
    ml
    >
    ><anonymous@discussions.microsoft.com> wrote in message
    news:487c01c47353$a8c26b10$a501280a@phx.gbl...
    >> Hmm. Not quite sure what your telling me to do. When
    I
    >> navigate to that key, shell Type is REG_SZ and Data is
    >> none. Under shell is find and under find are other
    >> entries. What to do? Thank you!
    >>
    >> Natasha
    >>
    >> >-----Original Message-----
    >> >Type regedit in Start Run and navigate to
    >> >
    >> >HKEY_CLASSES_ROOT\Directory\shell
    >> >
    >> >If after adding cmd to directories (known as File
    Folder
    >> in Filetypes - not all folders can have a command
    prompt,
    >> eg My Computer) the default command has changed type in
    >> Start Run
    >> >regsvr32 /i shell32
    >> >--
    >> >-------------------------------------------------------
    ---
    >> >'Not happy John! Defending our democracy',
    >>
    >http://www.smh.com.au/articles/2004/06/29/1088392635123.ht
    >> ml
    >> >
    >> >"Natasha" <anonymous@discussions.microsoft.com> wrote
    in
    >> message news:46f501c4734e$ac730940$a401280a@phx.gbl...
    >> >> I created a menu choice on the popup menu for
    folders
    >> to
    >> >> go to that directly to that directory in a DOS
    window,
    >> >> which is a very handy thing. Trouble is the first
    time
    >> I
    >> >> did it, I made a typo in the Action name and now I
    >> can't
    >> >> get rid of it. I am logged in with admin
    priveleges,
    >> but
    >> >> when I select the Action in the Edit File Type
    dialog,
    >> >> both the Edit and Remove buttons are always
    disabled.
    >> I
    >> >> also tried logging in as the true administrator to
    the
    >> >> machine, but the buttons were still disabled. Does
    >> anyone
    >> >> know any other way of getting rid of menu choices on
    >> the
    >> >> popup menu for a folder? There are other commands
    I'd
    >> >> like to get rid of as well. Thanks.
    >> >>
    >> >> Natasha
    >> >>
    >> >> PS Here is how you add the command to the popup
    menu:
    >> >>
    >> >> 1. Tools > Folder Options > File Types
    >> >>
    >> >> 2. Click Folder file type.
    >> >>
    >> >> 3. Click Advanced button.
    >> >>
    >> >> 4. Click New and configure:
    >> >>
    >> >> Action: Command Prompt Here
    >> >>
    >> >> Application Used to Perform Action:
    c:\windows\system32
    >> >> \cmd.exe /K cd
    >> >.
    >> >
    >.
    >
Ask a new question

Read More

Configuration File Type Windows XP