Sign in with
Sign up | Sign in
Your question

USB 3.0 ports not functioning.

Last response: in Motherboards
Share
October 26, 2012 11:02:35 AM

Motherboard: MSI H77MA-G43
Bios version: latest version (1.8)

The case doesn't have any USB 3.0 ports, so I am referring to the USB 3.0 ports that comes with the motherboard. When I plug in a USB 2.0 device, it doesn't even seem to power that device at all. Is there some wiring I should have plugged in?

More about : usb ports functioning

October 26, 2012 12:18:19 PM

The USB ports directly on the motherboard?
If your computer is running then your motherboard has power and your USB ports on it should have power. There is not additional wiring for that, or at least there shouldn't be.
The device works fine in other USB ports/other machines I take it?
October 26, 2012 1:50:36 PM

Yes, the device works fine. I've tried all sorts of devices: mouse, keyboard, USB HDD and USB flashdrive. All the other USB port work fine too. The only thing malfunctioning seems to be the USB port 3.0. I don't remember when they stop working though. Maybe it's after I flash the bios or attempt to install USB 3.0 drivers from the MSI website. Or maybe it's already not functioning out of the box.

Assuming that this is simple driver/software issue, how do I fix this?
Related resources
November 7, 2012 3:05:53 PM

Use Live Update from MSI to check for outdated or missing drivers.
November 8, 2012 12:37:50 AM

Updated all the drivers. Didn't do a thing. Finally fixed it by clearing the CMOS.
!