Sign-in / Sign-up
Your question
Closed

Flickering and artifacts on my display... please help

Tags:
  • Graphics Cards
  • Graphics
Last response: in Graphics Cards
August 4, 2011 6:57:38 PM

Please help me get on the right troubleshooting track for my graphics issues...

First the specs:
processor: intel i7 2600k (http://ark.intel.com/products/52214/Intel-Core-i7-2600K...)

mobo: asus p8z68v -pro (http://ca.asus.com/en/Motherboards/Intel_Socket_1155/pr...)

gpu: evga nvidia gtx 570 hd (http://www.evga.com/products/moreInfo.asp?pn=012-P3-157...)

monitor: samsung 24" 1920x1080 peak resolution with hdmi and digital driver installed from disc (will get model later if needed)

ram: (off the top of my head I think its this set) Kingston Intel X.M.P, DDR3-1600, unbuffered DIMM KHX1600C9D3K2/8GX (http://www.valueram.com/datasheets/KHX1600C9D3K2_8GX.pd...)

os: windows 7 64bit

psu: ocz elitexstream 1000w (eol, I know) (http://www.ocztechnology.com/ocz-elitexstream-power-sup...)


Anyways... I put that computer together a couple weeks ago, installed drivers from the discs, and updated some except the nvidia drivers via windows update (the nvidia I pulled from the site v275.33). About 2 weeks in, I noticed the desktop items flickering while I was looking through task manager while watching a video on vlc. After much playing around, Ive found almost all areas using transparency tend to flicker if dragging windows when I have a few different programs active, such as ie, firefox, vlc, wmp, task manager, explorer, windows mail, and perhaps others. Also, the display completely broke down a few times, turning windows black, or inactive, icons dissappearing, and occasional artifacts.

Since then, Ive turned off aero, and found that the flickering stopped almost completely, but I still see artifacts if I view hi-res images and various random times where I may be seeking through videos or just using explorer. The artifacts ( I think thats what theyre called ) are little blocks of solid color a few pixels wide that speckle an image. Also, the only game I've installed so far, shogun 2, plays perfectly on max settings, except on battle maps, there are the odd "spikes" of ground textures that shoot right up into the sky and seem completely inert otherwise. But no other noticeable issues.

So, first of all, should my system not be able to handle windows aero? I mean, Im fairly sure its powerful enough technically to handle the graphics. Second, how can I get rid of those damn artifacts or blocks?
Third: I tried updating certain intel driver software for the i7 desktop versions, and it told me my system does not meet the requirements. (yeah right). Are there any known resolutions to those issues?

Please let me know if you need more info...

More about : flickering artifacts display

Best solution

a c 238 U Graphics card
August 4, 2011 7:09:25 PM

Every time I've seen this type of issue, it's been due to a bad video card. They sometimes arrive with hardware problems. Do you have another video card you could test in your system to make sure it only happens on the 570?
Share
August 4, 2011 7:32:20 PM

bystander said:
Every time I've seen this type of issue, it's been due to a bad video card. They sometimes arrive with hardware problems. Do you have another video card you could test in your system to make sure it only happens on the 570?


The mobo has an integrated one that I haven't got around to trying again since I installed the 570. Thats my next step once I get home. So hardware's most likely then...
Score
0
Related resources
August 5, 2011 12:44:01 AM

I switched to iGPU and switched the cables around, restart, and image quality is great again, along with windows aero. so now I know its either the gpu or the psu not supplying enough amps to the gpu.

thanks buddy. :) 
Score
0
August 5, 2011 12:44:56 AM

Best answer selected by solid_shepard.
Score
0
a c 332 U Graphics card
August 5, 2011 12:49:06 AM

This topic has been closed by Mousemonkey
Score
0