Sign in with
Sign up | Sign in
Your question

Audio only works with headphones.

Last response: in Windows 7
Share
December 22, 2011 1:42:46 PM

Hey all,

I have Windows 7 ultimate.
Since a few weeks i have a problem with my sound.
My sound works with the regular audio jack where my headphones are connected.
But my high definition audio jacks don't work.

Anyways, here is how this happened.
I was experiencing some audio problems in certain games so i updated my audio drivers, sound works fine now but my speakers won't work.
Since windows 7 always installs drivers by itself it's annoying to try out other drivers, anyhow i managed to get the high definition audio drivers installed.but still no luck so i uninstalled them and let windows 7 install the audio drivers again.
Still no luck.
I also can't find anything about it in my BIOS, and i can't find anything wrong in the sound settings in windows either.

So i hope anyone could help me further solving this problem.

Thanks in advance!

More about : audio works headphones

a b $ Windows 7
a b \ Driver
December 22, 2011 2:01:20 PM

On-board sound or a PCI/PCIe card? Which motherboard?
December 22, 2011 2:06:11 PM

it's on-board sound and my motherboard is a gigabyte EX58-UD3R
Related resources
a b $ Windows 7
December 22, 2011 2:08:41 PM

hi Jonas

Right click the speaker icon in your system tray and open playback devices. Enable as default the device your speakers are connected to.

Exactly where is your headphone connected to? most speaker sets have a headphone jack on the volume controller thus all connecting to the same audio output in the system.
December 22, 2011 2:10:50 PM

Hey Boju

I've tried that before didn't work.then i don't have sound from my headphones and not from my speakers.

Well my headphones are connected to the jacks that are just above the high defintion audio jacks.
a b $ Windows 7
December 22, 2011 2:20:26 PM

what motherboard and speaker system do you have? Think maybe the way you have it setup is cancelling each other out software side.
December 22, 2011 2:22:50 PM

Gigabyte EX58-UD3R
System speakers: it's a logitech setup with a bass component(not sure how to say this in english) and i have 2 speakers connected to it.there is a possibility to connect more speakers to it tho.
December 22, 2011 2:24:24 PM

I just downloaded the realtek audio drivers from the gigabyte website which were suggested for my motherboard. Still not working.altho in the realtek audio program he does detect a detection on the 3 jacks
a b $ Windows 7
a b \ Driver
December 22, 2011 2:33:54 PM

In the BIOS the onboard sound is on the integrated peripherals page and called Azalia Codec, but that must be auto or enabled already since you get headphone sound.

Are your headphones in the rear green jack or in a front headphone jack? (The headphones in the front jack can mute the speakers on some sound chips, that can be disabled in the HD audio manager on yours.)

What are the settings when you look at the Realtec HD audio manager (double click on the little orange speaker in the system tray)?
December 22, 2011 2:41:32 PM

My buddy is in the same boat, i can get it working but its a pain. Almost the same motherboard as you. The work around we got on the go is by opening the sound application you installed. Then clicking on the auto detect options by right clicking and actually putting a check mark in the headphone jack when its plugged in the back. For some odd reason this makes the sound come out of the speaker jacks in the back. I've no idea why this works but it worked for my friend.
a b $ Windows 7
a b \ Driver
December 22, 2011 2:48:09 PM

Jonas1988 said:
I just downloaded the realtek audio drivers from the gigabyte website which were suggested for my motherboard. Still not working.altho in the realtek audio program he does detect a detection on the 3 jacks


Yes you need to use the Realtek audio manager and select the setup and id the speakers as you plug them in, (then turn off auto detection if you want). There are instructions for it at the end of your motherboard manual -- Gigabyte has used this for some time, on my P45 Gigabyte manual it is about 10 pages from the end.

Edit: and unplug your headphones when doing the speaker detection.
December 22, 2011 3:03:40 PM

My headphones are connected to the jacks behind.

As for the realtek device i've tried connecting them many times,he does detect it but there still is no sond.

@dormantreign

i'm not sure what to do when i read ur post tbh.
There isn't that much i can do in the realtek program for settings and configuration if you ask me.
December 22, 2011 3:12:29 PM

Alright,finally i got it working.
I messed around with some connection settings in realtek and now it works.
No idea why that even was wrong since it autodetected my speakers but apparently that was the solution.

I still find it strange because before when my speakers still worked i didn't even use realtek.

I want to thank you all for the fast answers and help!
Appreciated!
!