Sign-in / Sign-up
Your question

Pls help. PSU strange behaviour ?

Tags:
  • Power Supplies
  • Graphics Cards
  • Components
Last response: in Components
January 6, 2012 9:41:17 PM

Hello,

Basically i have a E6750 processor with 3Gb ddr2 ram,1 sata drive and 1 dvd drive attached to p31 neo motherboard running on 400W FSP model no:ATX-400PNF.

I wanted to upgrade my pci express graphic card to GTX 260 which i knew was power hungry and it will be risky to run it on my existing psu so i bough a hcs-620W antec power supply and attached the new graphic card to it. it ran for 2 days fine with no problems at all.

However i left the pc overnight to download some updates but when i woke up in the morning, the computer wouldnt boot up and the fan on the graphic card wasnt working. I took the card out and tested it on someone else pc and it worked fine. i attached a previous much slower card and i still had no display.

I also checked the outputs on the +12 rails and it was 12.1. fan on processor was turning on and so is the case fans and light. anyway i decided to put back my old psu and the computer booted up with no problems.

so far its running well and temperature of card at idle is 42 and while gaming on high setting it is around 70.
do i need to upgrade my psu or shall i leave it ??

More about : pls psu strange behaviour

a b ) Power supply
a b U Graphics card
January 6, 2012 10:22:57 PM

No. Rma the power supply to the vender or antec. I've dealt with antec before, and they took care of my problems twice. If you have the swap option, try an ocz or corsair ps; both are good values.