RAM halves in BIOS/memtest errors after crash during 3D games

I'm trying to figure out if this is bad ram, bad north bridge, bad CPU, or a bad graphics card. First off, up until about two weeks ago, everything was working fine since Feb 2011. I have a Phenom x6 1090T system w/ 16GB of patriot DDR3 memory, an ASUS M4A89GTD PRO/USB3 mobo and an MSI Twin Frozr II 2GB GTX 560Ti card with a built-in ATI chipset as well. I didn't do any overclocking recently and kept everything stock (the memory was actually running @ 1333mhz/1.6v but its 1600mhz memory that can OC to 2000mhz). I run Win 7 Ultimate 64-bit.

Again, everything's been working fine until very recently (last two weeks). I've recently seen issues while playing AOE3 where, after about 30 minutes of game play, my whole system would freeze up (video on nvidia goes black, video on ATI just shows the desktop as it did, but no mouse, etc) and I end up having to reset it. The bothersome part is after one of these trying moments I lost half my RAM in BIOS (it just vanished, but the chips were still there).

I had issues w/ the board before a BIOS update (beta 3030) about a year ago, so I left it all at stock and didn't bother trying to OC anymore. I do run both my Nvdia card and the built-in ATI card across 3 monitors. ATI uses UMA+Sideport although I believe I had turned off the sideport thing; regardless this was working fine.

I ran memtest on the 16gb of ram after I realized it had halved it in BIOS and found @ 8GB it had tons of errors (75K) by end of test 5. I removed all pieces but one, tested and requested RMA as I went through each stick. Once I had isolated it, I put in the good ram and ran another test to ensure no funny business. I thought the one bad stick was bad, so I loaded up AOE3 again and played it... sure enough about 30 minutes in BLAM. Crashola. I check memtest, this time one of the sticks that had registered as good was now showing some errors around 72mb.

As I've never had bad RAM, I decided I'd test my system by loading up TF2. No issues for hours. I then thought gee... Skyrim since its maxed out and uses every nook and cranny of my system (which I finished back in July with again, no issues at max settings ... used to run for hours just fine). After I loaded a saved game and did some moving between areas (maybe 5 minutes of graphics), the system froze and my 8GB of ram HALVED to 4GB in my bios (again!). I boot to windows and it says 8GB/4 usable, but BIOS displays 4GB. All of this used to display 16GB (14 or 15 usable) in windows, but now I'm getting bad memory issues and can't play 3D games without my system freaking out.

HELP! I'm going crazy here trying to figure out what could possibly be happening. Since RAM itself shouldn't be corruptible, in theory, why would the memory go bad just from running a game?! Could there be something wrong w/ my GPU vs. my memory or possibly north bridge / memory controller?! Unfortunately, my other system is DDR2 and won't take DDR3 so I can't test the memory on another system. :( I did update to the latest Nvidia driver a couple weeks ago, but is it possible that the GPU could affect physical RAM? UGH. I might try updating the ATI drivers, but I'm at my wits end as the RMA will be useless if it turns out to be deeper than just bad RAM.
3 answers Last reply
More about halves bios memtest errors crash games
  1. Check the CPU Pins , any bent pins could cause the memory to be read as only half since its responsible for the memory
  2. It might be also a temperature issue.
  3. After lots of monkeying around in the BIOS, I uninstalled all my video drivers and then re-installed. I noticed that w/ this BIOS rev, there were some graphics memory settings that were disabled by default, which could explain the crashing (Disabled for SP NB Termination and SP Memory Termination under the Internal Graphics Configuration..after er-enabling, didn't see 3D game crashes).

    It seems I can now play AOE3 w/o a crash; however, the memory still halves in BIOS either during windows boot (at splash screen...will just restart PC) or when it tries to access +4GB of memory (it crashes, then BIOS only shows ~4096MB of RAM at reboot).

    I thoroughly tested with and without onboard video and there's a slight 512MB difference when the onboard is enabled. Waiting on Patriot to send me new sticks to try out.

    I did notice a heating issue w/ the video card, might be dust related, although I think its failsafe 'feature.' If it gets above 104, the system freezes up/recycles. I'm still not sure why they don't design these cards like the old VESA / ISA cards where the chip/board was oriented so the heat would rise naturally. IMO, this would more efficiently reduce heating issues. It seems as it is, it has to pull the heat away from the chip downwards which kind of works against the laws of nature.

    Anyway, will post any future updates. Still a mystery as to why the memory is halving; I ran memtest86 and these sticks have no issues. I'll open a case w/ ASUS as the board should still be under warranty and see if they can give me any good reasons as to why this is happening.
Ask a new question

Read More

Asus RAM Motherboards