New Mobo- Will POST, but no BIOS

I'm trying to install a new motherboard, as my old one was failing. When I booted it up the first time, I get a GPU signature, and then a POST beep (but no splash screen). It then noticed the changed hardware and read "press F1 to enter setup, or F2 to load default values and continue". Being a new board, I press F1, then nothing happens. I get a blinking cursor. On reset, it doesn't even give me the option, and still no splash screen.

I've tried resetting the CMOS by removing the battery, and it'll give me that changed hardware option back, but only on the first boot. Again, it hangs with a cursor when I press F1.

Tried it with no Boot devices, one stick of RAM and video card only- issue persists.

I've never seen anything like it. It's like the BIOS is just missing! It posts, normal single beep code, but nothing from there.

Any help would be appreciated!

Current Specs:

Motherboard: MSI 970A-G46
CPU: AMD Athlon II X4 640
Corsair H60 Liquid CPU Cooler
RAM: Corsair Vengeance 16GB (2x8GB)
GPU: Galaxy GTX 560ti 1GB
PSU: Diablotek PHD Series 750W
HDD: Western Digital Blue 7200RPM 1TB
5 answers Last reply Best Answer
More about mobo post bios
  1. does beep only once? also try following ur MB manual to reset ur cmos
  2. If you use DVI, try the other DVI port. Some configs only post bios on one of the ports.
  3. Best answer
    RMA that sucker... it's still under warrenty.
  4. Best answer selected by bigwhiteyeti.
  5. Tried all of the above. It was a single beep, and I did try multiple DVI ports on my card. Returned it today for a new one.
Ask a new question

Read More