Sign in with
Sign up | Sign in
Your question

Rampage IV Extreme - Video Issues

Last response: in Motherboards
Share
November 2, 2012 4:12:15 PM


I recently purchased a Rampage IV Extreme and continue to have a few issues with this motherboard. I am seeking help and or advice on why these things are happening.

First of all let me add that everything is up to date. Bios, drivers, etc. I’ve even tried rolling back to older versions in hopes that maybe this is in part the problem. No good.

My primary problem is with the video. Right now I am running a single card located in the first PCI-E slot (per the book) and have tried moving this to other slots as well. The issue is that at least 50% of the time when I turn my PC on I get no video. The system always appears to boot into Windows (can tell by peripherals) however I have no display. No beeps, no error codes, etc. It may take 1, 2 or 3 three times (maybe more) of cycling the power before I finally get a display. Eventually, I can get into the system. As noted, this happens often. At least 50% of the time I turn on my PC.

Power is correctly applied to the video card in addition I have tried swapping this out with 2 other cards (3 different manufactures) and as noted; even changed PCI slots. The problem remains. All of the MB jumpers and switches seem to be properly in place (4-on) for the channels per the R4E manual.

While the system is active and I am gaming the video sometimes goes black like it lost connectivity however, this happens infrequently, say maybe once every few hours regardless of which video card or set of drivers. This most noticeably happens in Guild Wars 2. Likewise, the problem has occurred in both Windows 7 and 8 environments.

I can understand maybe power being an issue however I cannot understand how or why the CPU, Memory, Drivers or anything similar being a part of the issue. The power supply is plenty big enough and works flawlessly, at least so it appears. My only other thought is that could this be a bad signal going to my monitor?

I am seriously beginning to think that maybe I just picked a bad motherboard or maybe this MD is just no good.
a c 150 Ĉ ASUS
a c 557 V Motherboard
November 2, 2012 4:39:31 PM

What I can think of: a CPU installation issue (CPU socket bent pins, or heatsink overtightened), or a cable issue. I would reintall the CPU, check for bent pins and test the board outside of the case.
m
0
l
November 5, 2012 6:50:20 PM

It appears that not “everything” is compatible with PCIE-3 devices and/or the manufactures do not have all the bugs worked out.
Even though the motherboard and video card state otherwise. By stepping back/down to 2nd generation PCI settings in the BIOS on the motherboard the video card shows up every time I boot the PC. At least, for now.

I find this interesting in that while on Gen 3 the video issues during power-on were “part time” and when operational everything registered the video cards just fine and seemed to function ok (for the most part).

Hence stepping back to Gen2 appears to resolve the issue with the power on however, I still have in-game issues remaining. As noted, this can all be related to GW2.

Take note for anyone looking into such devices and expecting PCIe 3 to work:

EVGA GTX 660 (PCIe-3)
Asus Rampage IV Extreme (Intel Sock 2011/X79) PCIe-3 Ready (w/Intel I7 Second Gen processor)
NVidia: Geforce GTX 660TI (PCIe-3(replaced the EVGA))

After much research, my understanding is that this is a common issue with NVidia based cards only.
m
0
l
!