Sign in with
Sign up | Sign in
Your question

Asrock z77 extreme 4 wont turn on

Last response: in Motherboards
Share
November 2, 2012 10:24:28 PM

Hi i recently got a asrock z77 extreme 4 and installed it with a i5 3570k. i completed installation and posted my pc and went into the uefi bios. it all went pretty well but the second day i tried to turn on my computer it turned on but suddenly turned off after a couple min. in the bios. i tried the front panel power button and the mobo power button but it still wont turn on. the fans in the case would not work either so i thought that it was a psu failure (i have a ocz modxstream pro 700w). i contacted ocz tech support and they told me to do a paperclip trick with the mobo 24pin. it turned on my computer components so it means that it was a mobo problem but i didnt see how the mobo would short circuit since i didnt hear anything and there was nothing really wrong with mobo as far as the eye can see.
Thanks for the help
November 4, 2012 1:27:59 AM

already did that but nothing worked
m
0
l
!