Sign in with
Sign up | Sign in
Your question

Asus P9X79 Pro USB 3.0 ports

Last response: in Motherboards
Share
November 4, 2012 12:43:29 PM

Hi,

I have Asus P9X79 Pro and all four USB 3.0 ports on the back panel suddenly slowed down to the speed of USB 2.0. Interestingly, the USB 3.0 ports on the front panel still work with the proper USB 3.0 speed. All of them were tested with at least 3 different peripheral products: 2 different USB 3.0 memory card readers and an external USB 3.0 HDD.

Here is my exact configuration:
Board: ASUSTeK COMPUTER INC. P9X79 PRO Rev 1.xx
BIOS: American Megatrends Inc. 3009 10/05/2012
Windows 7 Ultimate (x64) Service Pack 1 (build 7601)

It's really strange, because according to ASUS technical support there are only 2 USB controllers on this motherboard, one for USB 3.0 and another one for all USB 2.0, so logically all USB 3.0 should act exactly the same, but they don't.

I played with BIOS a bit, turned on and off all USB legacy support, but it didn't change anything.
Then I decided to try it with Windows 8 Pro x64, installed on a separate drive, but it didn't change the situation either.

Any suggestions?

Your replies will be appreciated.
Regards,
Peter
a c 150 Ĉ ASUS
a c 559 V Motherboard
November 4, 2012 4:19:00 PM

Hi, I see 2 ways: install an USB 3.0 bracket connected to the motherboard 3.0 ports or RMA the board.
m
0
l
November 4, 2012 5:42:32 PM

Hi,

I did almost anything you can think of, including the CMOS reset and the installation of the brand new ASM USB driver and ... it's working as expected now!

I am unable to tell what exactly did the trick, but it was probably the CMOS clearing and the installation of the new driver combined.

PS. The newest ASM driver is available here:
http://www.overclock.net/t/1193055/asus-x79-series-info...


Regards,
Peter
m
0
l
!