Sign in with
Sign up | Sign in
Your question

Computer turns on, no display, DRAM light on

Last response: in Motherboards
Share
November 4, 2012 5:05:15 PM

Help me please! I've never built a computer before. I purchased all the parts off Newegg and assembled it. Here are my specs:
motherboard: ASUS P8Z77-V LK
cpu: Intel Core i5-3550 Ivy Bridge
RAM: Kingston HyperX 2x4gb
psu: Corsair TX650 V2 650W ATX12V Plus Bronze
videocard: EVGA GeForce GTX 560 Ti

When I turn on my computer, the fans and lights power on. At first, the DRAM LED was continuously lit (red). There was no beeping noise, but the monitor would say 'No signal'. I tried plugging it into both the integrated graphics and the video card, but neither worked.
And then I think I removed the RAM and put it back in, and now there's a continuous red DRAM LED, and there's a beeping noise that indicates 'no memory detected', according to the mobo manual.
What's gone wrong with my build?? I don't understand
a c 150 Ĉ ASUS
a c 558 V Motherboard
November 4, 2012 5:48:07 PM

Have you properly inserted the RAM stick (don't push too hard though)? Test the board with only one RAM stck installed. What's the RAMs model?
m
0
l
November 4, 2012 6:04:02 PM

I tried installing both sticks of RAM into A2B2 and A1B1, and I tried installing only one stick of RAM into A2, and then tried the other stick of RAM.
Is it a RAM problem?
m
0
l
Related resources
November 4, 2012 6:05:33 PM

Kingston HyperX 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model KHX1600C9D3K2/8GX
^is my RAM
m
0
l
a c 150 Ĉ ASUS
a c 558 V Motherboard
November 4, 2012 6:13:57 PM

Since the DRAM led remains lit and you get one long 2 short beeps, then it's a memory issue. The RAMs are compatible. Try taking the board outside of the case, make sure you have properly connected both 24 and 8-pin power connectors and make sure the RAM stick is properly inserted. I still think that you don't insert the RAM properly.
m
0
l
a c 116 Ĉ ASUS
a c 462 V Motherboard
November 4, 2012 7:43:20 PM

two other thing will cause a no post or ram issue on the newer cpu. if your using an after market heat sink and it has a metal back plate it can sort the mb out. or with the cpu heat sink if it locked down to tight it can bend the cpu and cause strange issues. the last is as the memory contoller is inside the intel cpu the cpu could be bad or there a bent pin under the cpu.
m
0
l
a b Ĉ ASUS
a c 143 V Motherboard
November 4, 2012 7:45:18 PM

see your user board manual page 2-42 motherboard do not detect memory did you try the mem ok button on the board ans start with a2 then if boot add b2,seat hte memory stick in the slot until the little latch lock on each side on them
m
0
l
November 6, 2012 5:29:08 PM

I adjusted the RAM sticks and the beeping noise disappeared - good call there!

However, the DRAM light is still on continuously. Is that normal?
Also, there is still no display on my monitor. Any advice on how to fix that?
m
0
l
November 6, 2012 5:36:51 PM

Okay, the system isn't booting up completely. It's stuck at some check in the bootup, which is why the DRAM light is on.
Can anyone give me some advice on where to check for problems?
m
0
l
a b Ĉ ASUS
a c 143 V Motherboard
November 6, 2012 6:37:47 PM

try to post only with one ram stick in the a channel first slot
m
0
l
!